phpBB3 forum - Force HTTPS

Få hjælp til at sætte programmer eller funktioner op.
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

phpBB3 forum - Force HTTPS

Indlæg af Spotten »

Hej.

Jeg har lige installeret LAMP og et phpBB3 board.

Da jeg satte dette op satte jeg den til at bruge https://, jeg kan dog ikke huske hvad de forskellige ting her derinde da jeg ikke har rodet så meget med det før.

Når jeg åbner localhost i min firefox browser, så viser den indholdet, mine apache mappe, og min phpBB3 mappe, og når jeg går ind i min phpBB3 mappe, så vises den også fint, men idet jeg forsøger at logge ind laver den en fejl og jeg kommer ikke videre.

Jeg kan ikke lige se hvordan jeg skal kunne komme ind i phpBB3 boardet og ændre denne fejl.

Når jeg trykket login skifter linket fra localhost/phpBB3 til https://localhost:80/phpBB3/index.php?sid=a4a32ee1636fae6b3d79ed4dd15a477e og kommer med følgende fejl:

Billede

Jeg kan ikke lige se hvordan jeg igen skal kunne tilgå mit board og ændre disse indstilninger så det virker?

Skal jeg slette det hele og starte forfra? Har ikke sat noget op endnu så det ville ikke gøre så meget.

På forhånd tak.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: phpBB3 forum - Force HTTPS

Indlæg af AJenbo »

Jeg forslår du sletter det hele (databasen) og starter for fra. Ellers skal du enten ændre det manuelt i databasen eller sætte https op på din server.
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

AJenbo skrev:Jeg forslår du sletter det hele (databasen) og starter for fra. Ellers skal du enten ændre det manuelt i databasen eller sætte https op på din server.


Det kunne godt lyde som noget for mig? Det med at sætte HTTPS op på min server, hvordan gør jeg dette?

Det skal lige siges at "serveren" kører på min normale maskine, dvs. den jeg bruger til alt, jeg har ikke planer om at få hosted den lige pt. måske på et tidspunkt, men ikke til at starte med i hvert fald.

På forhånd tak.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: phpBB3 forum - Force HTTPS

Indlæg af AJenbo »

https://www.digitalocean.com/community/tutorials/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-12-04

Demærk at når du selv signere certifikatet vil det ikke automatisk blive godkendt og alle brugere vil få en meget skarp advarsel når de besøger siden. For at løse det skal du betale for et gyldigt certifikat og et domæne.
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

AJenbo skrev:https://www.digitalocean.com/community/tutorials/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-12-04

Demærk at når du selv signere certifikatet vil det ikke automatisk blive godkendt og alle brugere vil få en meget skarp advarsel når de besøger siden. For at løse det skal du betale for et gyldigt certifikat og et domæne.


Ja det ved jeg godt, det er også kun mit personlige site som ikke skal offentliggøres i den forstand, bare så jeg har et sted hvor jeg kan have mine ting og evt linke til og dele med dem jeg nu ønsker at dele med.

Vil det være et problem at have siden liggende lokalt på min computer og så tilgå den udefra via min WAN IP?

Jeg har før haft en lille hjemmeside liggende på min computer på denne måde uden problemer, det har virket fint, det er bare meget længe siden jeg har brugt det og har derfor stort set glemt alt om hvordan man sætter det hele op! :)

Jeg er lidt i tvivl om hvilken del af den guide du linker til jeg skal bruge, apache har jeg jo inde? Kan se der er en masse forkellige kommandoer, men det ser ikke ud til jeg skal bruge dem allesammen?

På forhånd tak.

EDIT: Fik denne besked, er lidt i tvivl om hvad det betyder?

Kode: Vælg alt

spot@SPOT-PC:~$ sudo service apache2 restart
 * Restarting web server apache2                                                AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
                                                                         [ OK ]
spot@SPOT-PC:~$


EDIT: Hvilken IP er det der tales om her? Min lokale eller min WAN?

The most important line is "Common Name". Enter your official domain name here or, if you don't have one yet, your site's IP address.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: phpBB3 forum - Force HTTPS

Indlæg af AJenbo »

Meldingen du får i terminalen betyder din side liggende lokalt på din computer. Nej det er ikke et problem.
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

AJenbo skrev:Meldingen du får i terminalen betyder din side liggende lokalt på din computer. Nej det er ikke et problem.


Nå nu virker det tilsyneladende, måske jeg skal åbne port 443 i min router, det ser ikke ud til jeg får lov at logge ind, samme fejl som i starten!
Senest rettet af Spotten 30. sep 2015, 05:26, rettet i alt 1 gang.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: phpBB3 forum - Force HTTPS

Indlæg af AJenbo »

Spotten skrev:The most important line is "Common Name". Enter your official domain name here or, if you don't have one yet, your site's IP address.


Det er den adresse som man vil tilgå siden på. Det vil sige hvis den skal kunne tilgåes af folk der ikke nødvendigvis bruger din computer skal det ikke være localhost/127.0.0.1 og hvis det skal kunne tilgåes af folk som ikke er på besøg hjemme hos dig skal det være din WAN IP.
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

AJenbo skrev:
Spotten skrev:The most important line is "Common Name". Enter your official domain name here or, if you don't have one yet, your site's IP address.


Det er den adresse som man vil tilgå siden på. Det vil sige hvis den skal kunne tilgåes af folk der ikke nødvendigvis bruger din computer skal det ikke være localhost/127.0.0.1 og hvis det skal kunne tilgåes af folk som ikke er på besøg hjemme hos dig skal det være din WAN IP.


Nå for satan! Så er det måske derfor det ikke virker, brugte min LAN IP, og den fejler stadig når jeg forsøger at logge ind.

Samme fejl som første billede i første indlæg.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

Kan det være fordi jeg sidder på maskinen jeg forsøger at tilgå?

Denne adresse virker fint i min browser (FF) : https://localhost/ så det med HTTPS ser ud til at virke, men så snart jeg forsøger at logge ind f.eks for at lave ændringer i forum, så får jeg samme besked som i mit første indlæg i denne tråd.

Den smider mig herhen: https://localhost:80/phpBB3/index.php?sid=6ddbb1259e6e62e407f236ecdcc7c3a4

Samme fejl stadig:

Billede

Det virker fint med SSL certifikatet, men når jeg prøver at logge ind så sender dig mig et forkert sted hen, som om den re-directer forkert eller noget.

Det virker både med http://localhost samt med https://localhost, men når jeg prøver at logge ind går det galt som i kan se.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

Jeg er lidt i tvivl om hvad jeg skal slette for at geninstallere dette phpBB forum, jeg ville dog stadig gerne have der var kryptering på, men det virker som om den fejl jeg får måske er for kompliceret til at rode med den, og det måske bedre kan betale sig at "geninstallere" forummet nu hvor det intet indhold har indtil videre alligevel.

Hvis jeg gerne vil have HTTPS, hvordan gør man så dette?

Jeg har som sagt LAMP installeret samt phpBB3 forum og det har virket førhen, men der havde jeg så vidt jeg husker også nogle problemer ala dette, jeg synes dog ikke jeg kan finde noget i min tidligere tråd ang. dette problem.
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

Jeg har geninstalleret det og nu virker det som det skal, dog kun lokalt.

Jeg gad godt vide hvordan jeg f.eks kan lade andre tilgå mit forum udefra?

Bruger jeg https://minipadresse/phpBB3 så sker der intet måske jeg SKAL definere porten som er 443?
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: phpBB3 forum - Force HTTPS

Indlæg af AJenbo »

Du skal forwarde porten i din ruter, port http er 80 og https er port 443.

Fejlen du får ved tilgang via https skyldes manglende SSL opsætning i Apache.
Spotten
Indlæg: 2135
Tilmeldt: 19. okt 2007, 18:13
IRC nickname: Sp0t
Geografisk sted: Jamaica

Re: phpBB3 forum - Force HTTPS

Indlæg af Spotten »

Fejlen får jeg ikke længere, det virker fint, dog kun via localhost.

Jeg ville gerne have at man skulle kunne tilgå min "server" udefra via min WAN IP, men måske jeg mangler at sætte noget op?

Jeg har sat LAMP op, Linux, Apache, MySQL, PHP, OpenSSL, Udover det fik jeg det til at due efter den guide du linkede til ang. selvskrevne SSL certifikater, den viser også certificatet fint osv, men stadig foregår alt dette lokalt.

phpBB boardet er også oppe når jeg kigger herfra, lokalt altså, og den finder også nemt rooten hvor min apache og Wordpress også ligger og de virker også fint, stadig kun lokalt.

Jeg har været inde og forwarde porte, både port 80 og port 443, så det burde virke?
MB : Asus Sabertooth Z77
CPU : Intel Core I7 2600K+ 3,4GHz 8Mb L3
RAM : 4x4GB Corsair DDR3 1600MHz
HDD : LAGER : 1x1TB WD Extern USB 7200rpm + SYSTEM 1 x 180GB Corsair Force 3 Series SSD SATA6 550MB/sek
GFX : MSI 7900GT 512MB GDDR3 (Passivt Kølet)
Case : Lian Li PC-V1100 Plus
PSU : Corsair Professionel Series Gold AX1200
OS: Ubuntu 18.01LTS 64bit
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: phpBB3 forum - Force HTTPS

Indlæg af AJenbo »

Du skal forward porten i din ruter, kontakt eventuelt dem du har købt den fra hvis ikke du kan se det ud af manualen