Kan ikke installere Epson driver

Scannere, kameraer, printere, mus, tegneplader osv.
CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Kan ikke installere Epson driver

Indlægaf CityTop » 20. aug 2015, 10:41

Jeg har et problem med at installere en Epson printer driver. Kan nogen hjælpe mig med at se, hvor fejlen er?

Jeg kører kommandoen:

Kode: Vælg alt

sudo dpkg -i /var/cache/apt/archives/epson-inkjet-printer-201101w_1.0.0-1lsb3.2_amd64.deb


og får:

Kode: Vælg alt

Selecting previously unselected package epson-inkjet-printer-201101w.
(Reading database ... 241525 files and directories currently installed.)
Preparing to unpack .../epson-inkjet-printer-201101w_1.0.0-1lsb3.2_amd64.deb ...
Unpacking epson-inkjet-printer-201101w (1.0.0-1lsb3.2) ...
dpkg: dependency problems prevent configuration of epson-inkjet-printer-201101w:
 epson-inkjet-printer-201101w depends on lsb (>= 3.2); however:
  Package lsb is not installed.

dpkg: error processing package epson-inkjet-printer-201101w (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 epson-inkjet-printer-201101w


derefter kommandoen:

Kode: Vælg alt

sudo apt-get -f install


som giver:

Kode: Vælg alt

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  alien at debhelper debugedit dh-apparmor heirloom-mailx lib32z1 libc6-i386
  libjpeg62 libmail-sendmail-perl libpod-plainer-perl librpm3 librpmbuild3
  librpmio3 librpmsign1 libsigsegv2 libsys-hostname-long-perl lsb lsb-core
  lsb-cxx lsb-desktop lsb-graphics lsb-invalid-mta lsb-languages
  lsb-multimedia lsb-printing lsb-security m4 pax po-debconf rpm rpm-common
  rpm2cpio
Suggested packages:
  lsb-rpm default-mta mail-transport-agent dh-make rpm-i18n apparmor-easyprof
  libmail-box-perl elfutils
Recommended packages:
  libqt3-mt
The following NEW packages will be installed:
  alien at debhelper debugedit dh-apparmor heirloom-mailx lib32z1 libc6-i386
  libjpeg62 libmail-sendmail-perl libpod-plainer-perl librpm3 librpmbuild3
  librpmio3 librpmsign1 libsigsegv2 libsys-hostname-long-perl lsb lsb-core
  lsb-cxx lsb-desktop lsb-graphics lsb-invalid-mta lsb-languages
  lsb-multimedia lsb-printing lsb-security m4 pax po-debconf rpm rpm-common
  rpm2cpio
0 upgraded, 33 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
Need to get 0 B/4.318 kB of archives.
After this operation, 16,3 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Selecting previously unselected package lsb-invalid-mta.
(Reading database ... 241567 files and directories currently installed.)
Preparing to unpack .../lsb-invalid-mta_4.1+Debian11ubuntu6_all.deb ...
Unpacking lsb-invalid-mta (4.1+Debian11ubuntu6) ...
Selecting previously unselected package at.
Preparing to unpack .../at_3.1.14-1ubuntu1_amd64.deb ...
Unpacking at (3.1.14-1ubuntu1) ...
Selecting previously unselected package libsigsegv2:amd64.
Preparing to unpack .../libsigsegv2_2.10-2_amd64.deb ...
Unpacking libsigsegv2:amd64 (2.10-2) ...
Selecting previously unselected package m4.
Preparing to unpack .../m4_1.4.17-2ubuntu1_amd64.deb ...
Unpacking m4 (1.4.17-2ubuntu1) ...
Selecting previously unselected package heirloom-mailx.
Preparing to unpack .../heirloom-mailx_12.5-2+deb7u1build0.14.04.1_amd64.deb ...
Unpacking heirloom-mailx (12.5-2+deb7u1build0.14.04.1) ...
Selecting previously unselected package pax.
Preparing to unpack .../pax_1%3a20120606-2+deb7u1_amd64.deb ...
Unpacking pax (1:20120606-2+deb7u1) ...
Selecting previously unselected package po-debconf.
Preparing to unpack .../po-debconf_1.0.16+nmu2ubuntu1_all.deb ...
Unpacking po-debconf (1.0.16+nmu2ubuntu1) ...
Selecting previously unselected package dh-apparmor.
Preparing to unpack .../dh-apparmor_2.8.95~2430-0ubuntu5.3_all.deb ...
Unpacking dh-apparmor (2.8.95~2430-0ubuntu5.3) ...
Selecting previously unselected package debhelper.
Preparing to unpack .../debhelper_9.20131227ubuntu1_all.deb ...
Unpacking debhelper (9.20131227ubuntu1) ...
Selecting previously unselected package librpmio3.
Preparing to unpack .../librpmio3_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking librpmio3 (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package librpm3.
Preparing to unpack .../librpm3_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking librpm3 (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package librpmbuild3.
Preparing to unpack .../librpmbuild3_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking librpmbuild3 (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package librpmsign1.
Preparing to unpack .../librpmsign1_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking librpmsign1 (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package rpm-common.
Preparing to unpack .../rpm-common_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking rpm-common (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package rpm2cpio.
Preparing to unpack .../rpm2cpio_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking rpm2cpio (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package debugedit.
Preparing to unpack .../debugedit_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking debugedit (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package rpm.
Preparing to unpack .../rpm_4.11.1-3ubuntu0.1_amd64.deb ...
Unpacking rpm (4.11.1-3ubuntu0.1) ...
Selecting previously unselected package alien.
Preparing to unpack .../archives/alien_8.90_all.deb ...
Unpacking alien (8.90) ...
Selecting previously unselected package libc6-i386.
Preparing to unpack .../libc6-i386_2.19-0ubuntu6.6_amd64.deb ...
Unpacking libc6-i386 (2.19-0ubuntu6.6) ...
Replaced by files in installed package libc6:i386 (2.19-0ubuntu6.6) ...
Selecting previously unselected package lib32z1.
Preparing to unpack .../lib32z1_1%3a1.2.8.dfsg-1ubuntu1_amd64.deb ...
Unpacking lib32z1 (1:1.2.8.dfsg-1ubuntu1) ...
Selecting previously unselected package lsb-security.
Preparing to unpack .../lsb-security_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-security (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb-core.
Preparing to unpack .../lsb-core_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-core (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb-graphics.
Preparing to unpack .../lsb-graphics_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-graphics (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb-cxx.
Preparing to unpack .../lsb-cxx_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-cxx (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb-multimedia.
Preparing to unpack .../lsb-multimedia_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-multimedia (4.1+Debian11ubuntu6) ...
Selecting previously unselected package libjpeg62:amd64.
Preparing to unpack .../libjpeg62_6b1-4ubuntu1_amd64.deb ...
Unpacking libjpeg62:amd64 (6b1-4ubuntu1) ...
Selecting previously unselected package lsb-desktop.
Preparing to unpack .../lsb-desktop_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-desktop (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb-printing.
Preparing to unpack .../lsb-printing_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-printing (4.1+Debian11ubuntu6) ...
Selecting previously unselected package libpod-plainer-perl.
Preparing to unpack .../libpod-plainer-perl_1.03-1_all.deb ...
Unpacking libpod-plainer-perl (1.03-1) ...
Selecting previously unselected package lsb-languages.
Preparing to unpack .../lsb-languages_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-languages (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb.
Preparing to unpack .../lsb_4.1+Debian11ubuntu6_all.deb ...
Unpacking lsb (4.1+Debian11ubuntu6) ...
Selecting previously unselected package libsys-hostname-long-perl.
Preparing to unpack .../libsys-hostname-long-perl_1.4-3_all.deb ...
Unpacking libsys-hostname-long-perl (1.4-3) ...
Selecting previously unselected package libmail-sendmail-perl.
Preparing to unpack .../libmail-sendmail-perl_0.79.16-1_all.deb ...
Unpacking libmail-sendmail-perl (0.79.16-1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for install-info (5.2.0.dfsg.1-2) ...
Processing triggers for doc-base (0.10.5) ...
Processing 1 added doc-base file...
Setting up lsb-invalid-mta (4.1+Debian11ubuntu6) ...
Setting up at (3.1.14-1ubuntu1) ...
atd start/running, process 25959
Setting up libsigsegv2:amd64 (2.10-2) ...
Setting up m4 (1.4.17-2ubuntu1) ...
Setting up heirloom-mailx (12.5-2+deb7u1build0.14.04.1) ...
update-alternatives: using /usr/bin/heirloom-mailx to provide /usr/bin/mailx (mailx) in auto mode
Setting up pax (1:20120606-2+deb7u1) ...
Setting up po-debconf (1.0.16+nmu2ubuntu1) ...
Setting up dh-apparmor (2.8.95~2430-0ubuntu5.3) ...
Setting up debhelper (9.20131227ubuntu1) ...
Setting up librpmio3 (4.11.1-3ubuntu0.1) ...
Setting up librpm3 (4.11.1-3ubuntu0.1) ...
Setting up librpmbuild3 (4.11.1-3ubuntu0.1) ...
Setting up librpmsign1 (4.11.1-3ubuntu0.1) ...
Setting up rpm-common (4.11.1-3ubuntu0.1) ...
Setting up rpm2cpio (4.11.1-3ubuntu0.1) ...
Setting up debugedit (4.11.1-3ubuntu0.1) ...
Setting up rpm (4.11.1-3ubuntu0.1) ...
Setting up alien (8.90) ...
Setting up libc6-i386 (2.19-0ubuntu6.6) ...
Setting up lib32z1 (1:1.2.8.dfsg-1ubuntu1) ...
Setting up lsb-security (4.1+Debian11ubuntu6) ...
Setting up libjpeg62:amd64 (6b1-4ubuntu1) ...
Setting up libpod-plainer-perl (1.03-1) ...
Setting up libsys-hostname-long-perl (1.4-3) ...
Setting up libmail-sendmail-perl (0.79.16-1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Setting up lsb-core (4.1+Debian11ubuntu6) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package lsb-core (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of lsb-graphics:
 lsb-graphics depends on lsb-core (>= 4.1+Debian11ubuntu6); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb-graphics (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb-cxx:
 lsb-cxx depends on lsb-core (>= 4.1+Debian11ubuntu6); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb-cxx (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb-multimedia:
 lsb-multimedia depends on lsb-core (>= 4.1+Debian11ubuntu6); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb-multimedia (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configurNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                    No apport report written because the error message indicates its a followup error from a previous failure.
              No apport report written because MaxReports is reached already
                                                                            No apport report written because MaxReports is reached already
                                                          No apport report written because MaxReports is reached already
                                        No apport report written because MaxReports is reached already
                      No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  ation of lsb-desktop:
 lsb-desktop depends on lsb-graphics (>= 4.1+Debian11ubuntu6); however:
  Package lsb-graphics is not configured yet.
 lsb-desktop depends on lsb-multimedia (>= 4.1+Debian11ubuntu6); however:
  Package lsb-multimedia is not configured yet.

dpkg: error processing package lsb-desktop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb-printing:
 lsb-printing depends on lsb-core (>= 4.1+Debian11ubuntu6); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb-printing (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb-languages:
 lsb-languages depends on lsb-core (>= 4.1+Debian11ubuntu6); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb-languages (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb:
 lsb depends on lsb-core (>= 4.1+Debian11ubuntu6); however:
  Package lsb-core is not configured yet.
 lsb depends on lsb-graphics (>= 4.1+Debian11ubuntu6); however:
  Package lsb-graphics is not configured yet.
 lsb depends on lsb-cxx (>= 4.1+Debian11ubuntu6); however:
  Package lsb-cxx is not configured yet.
 lsb depends on lsb-desktop (>= 4.1+Debian11ubuntu6); however:
  Package lsb-desktop is not configured yet.
 lsb depends on lsb-printing (>= 4.1+Debian11ubuntu6); however:
  Package lsb-printing is not configured yet.
 lsb depends on lsb-languages (>= 4.1+Debian11ubuntu6); however:
  Package lsb-languages is not configured yet.

dpkg: error processing package lsb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of epson-inkjet-printer-201101w:
 epson-inkjet-printer-201101w depends on lsb (>= 3.2); however:
  Package lsb is not configured yet.

dpkg: error processing package epson-inkjet-printer-201101w (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
Errors were encountered while processing:
 lsb-core
 lsb-graphics
 lsb-cxx
 lsb-multimedia
 lsb-desktop
 lsb-printing
 lsb-languages
 lsb
 epson-inkjet-printer-201101w
E: Sub-process /usr/bin/dpkg returned an error code (1)
Senest rettet af CityTop 20. aug 2015, 15:13, rettet i alt 1 gang.

Stra
Indlæg: 3105
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Kan ikke installere Epson driver

Indlægaf Stra » 20. aug 2015, 12:20

CityTop skrev:dpkg: dependency problems prevent configuration of epson-inkjet-printer-201101w:
epson-inkjet-printer-201101w depends on lsb (>= 3.2); however:
Package lsb is not installed.
Den siger der mangler en pakke .
Prøv

Kode: Vælg alt

sudo apt-get install lsb
stra
Bruger Ubuntu 22.04 og 22.10 + lubuntu 22.10

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Re: Kan ikke installere Epson driver

Indlægaf CityTop » 20. aug 2015, 15:20

Tak.

jeg prøver

Kode: Vælg alt

sudo apt-get install lsb

og får

Kode: Vælg alt

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.


så jeg kører

Kode: Vælg alt

sudo dpkg --configure -a

og får
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libjpeg62:amd64 (6b1-4ubuntu1) ...
Setting up dh-apparmor (2.8.95~2430-0ubuntu5.3) ...
Processing triggers for doc-base (0.10.5) ...
Processing 1 changed doc-base file...
Setting up libsigsegv2:amd64 (2.10-2) ...
Setting up librpmio3 (4.11.1-3ubuntu0.1) ...
Setting up at (3.1.14-1ubuntu1) ...
Processing triggers for ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Setting up librpm3 (4.11.1-3ubuntu0.1) ...
Setting up po-debconf (1.0.16+nmu2ubuntu1) ...
Setting up debhelper (9.20131227ubuntu1) ...
Setting up debugedit (4.11.1-3ubuntu0.1) ...
Setting up librpmbuild3 (4.11.1-3ubuntu0.1) ...
Setting up rpm-common (4.11.1-3ubuntu0.1) ...
Setting up rpm2cpio (4.11.1-3ubuntu0.1) ...
Setting up librpmsign1 (4.11.1-3ubuntu0.1) ...
Setting up rpm (4.11.1-3ubuntu0.1) ...
Setting up alien (8.90) ...
Setting up lsb-core (4.1+Debian11ubuntu6) ...
Setting up lsb-multimedia (4.1+Debian11ubuntu6) ...
Setting up lsb-printing (4.1+Debian11ubuntu6) ...
Setting up lsb-graphics (4.1+Debian11ubuntu6) ...
Setting up lsb-languages (4.1+Debian11ubuntu6) ...
Setting up lsb-cxx (4.1+Debian11ubuntu6) ...
Setting up lsb-desktop (4.1+Debian11ubuntu6) ...
Setting up lsb (4.1+Debian11ubuntu6) ...
Setting up epson-inkjet-printer-201101w (1.0.0-1lsb3.2) ...
cups stop/waiting
cups start/running, process 5406
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

kører igen

Kode: Vælg alt

sudo dpkg -i /var/cache/apt/archives/epson-inkjet-printer-201101w_1.0.0-1lsb3.2_amd64.deb

og får
(Reading database ... 242763 files and directories currently installed.)
Preparing to unpack .../epson-inkjet-printer-201101w_1.0.0-1lsb3.2_amd64.deb ...
Unpacking epson-inkjet-printer-201101w (1.0.0-1lsb3.2) over (1.0.0-1lsb3.2) ...
cups stop/waiting
cups start/running, process 5477
Setting up epson-inkjet-printer-201101w (1.0.0-1lsb3.2) ...
cups stop/waiting
cups start/running, process 5532
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

Det ser normalt ud, så jeg kører

Kode: Vælg alt

sudo apt-get -f install


Det giver:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

Så vidt jeg kan se ved at gå ind i settings, er printeren dog stadig ikke installeret.
Senest rettet af CityTop 20. aug 2015, 16:00, rettet i alt 1 gang.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke installere Epson driver

Indlægaf AJenbo » 20. aug 2015, 15:31

Du har kun installeret driveren, du skal nu sætte printeren op inde i systemindstillinger.

I øvrigt vil jeg da lige forslå at du installere de 4 opdateringer der afventer.

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Re: Kan ikke installere Epson driver

Indlægaf CityTop » 20. aug 2015, 15:58

OK. Tak. Det vil jeg gøre, så snart jeg er hjemme og kan tilslutte min laptop til printeren.

Mener du almindelig opdatering af pakker med apt-get update og apt-get upgrade?

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke installere Epson driver

Indlægaf AJenbo » 20. aug 2015, 16:19

Ja (du behøves ikke update da den allerede har opdaget de 4 opdateringer) f.eks. Men den grafiske opdateringshåndteringen skulle også være fint

Tilbage til "Ekstern hardware"

Hvem er online

Brugere der læser dette forum: Ingen og 0 gæster