Opsætning af ekstern harddisk

Få hjælp til at sætte programmer eller funktioner op.
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opsætning af ekstern harddisk

Indlæg af AJenbo »

Mit gæt er strømforbrug
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Strømforbrug - også selv om den har egen strømforsyning?
Kan der være forskel på den driver, der bruges i Ubuntu og i Mint?
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Jeg tror, fejlen ligger i docken. Jeg satte en anden harddisk i, og nu viste den samme fejl.
Tak for hjælpen. Det var en umulig opgave, jeg havde sat jer på.
Mange hilsner
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: Opsætning af ekstern harddisk

Indlæg af thj01 »

Hvis den kører med Mint, så er problemet nok snarere måden som Ubuntu mounter drevet og hvilke betingelser der er for afmontering.

Og der er nogle spørgsmål som lige skal afklares.

"forsvindere" drevet imens det kopiere filer, eller det kun når det står "stand by"?

Er det samme problemstilling hvis du mounter drevet manuelt?

Hvad siger kommandoen "lsblk" (lister tilgængelige systemer)

2. Angående strømforsyning. En af de hyppigste fejl jeg oplever ved ekstern udstyr er netop Strømforsyningen. Og jeg har en transportabel harddisk hvis største problem netop er strømforsyningen. Så bare ved at skrifte strømforsyning fungerede det hele igen. Det er også en fantastisk løsningsmodel, hvis ens router pludselig bliver ustabil.
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Jeg har en anden ekstern harddisk, som kører uden problemer, så jeg tror fejlen ligger i hardware - enten disk eller strømforsyning. Både disk og docking er ret nye, så jeg vil forsøge at returnere dem før jeg prøver andet.
Vh
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opsætning af ekstern harddisk

Indlæg af AJenbo »

Det ville nok være en god ide at tjekke om disken er synlig under /dev eller med kommandoen "df -h" når den afmontere.
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Hej
Tak for jeres ihærdighed.
Hvad betyder
synlig under /dev
?
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opsætning af ekstern harddisk

Indlæg af AJenbo »

Mappen /dev indeholder en liste af hardware, harddiske vil normalt optræde som sd? hvor ? er et bogstav fra a-z, der vil også være en liste med partitioner som er det samme sd? efterfulgt af et tal for partitions nummeret. Installationen for Ubuntu vil ofte ligge på /dev/sda1 hvilket du muligvis har set før?
thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: Opsætning af ekstern harddisk

Indlæg af thj01 »

Prøv at køre kommandoen "lsblk" - det er en effektiv måde at se hvad der er monteret og hvor.

Så kan du se hvad der er monteret op systemet

Kode: Vælg alt

thoj@thoj-Precision-M4800:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0   477G  0 disk
├─sda1   8:1    0   350M  0 part
├─sda2   8:2    0  48,5G  0 part
├─sda4   8:4    0     1K  0 part
├─sda5   8:5    0  15,3G  0 part [SWAP]
├─sda6   8:6    0 301,1G  0 part /data
└─sda7   8:7    0 111,8G  0 part /
sdb      8:16   1   3,8G  0 disk
└─sdb1   8:17   1   3,8G  0 part /media/thoj/C971-855A
sr0     11:0    1  1024M  0 rom
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Jeg havde ellers opgivet den, men efter jeres indlæg har jeg tilsluttet den igen, og den har kørt med kun en afmontering siden i går aftes. Jeg har belastet den meget med store filoverførsler, men afmonteringen skete mens den ikke var i brug.
Kommandoen "lsblk" giver flg. output, som vel ser rigtigt ud.

Kode: Vælg alt

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 119,2G  0 disk
├─sda1   8:1    0 111,4G  0 part /
├─sda2   8:2    0     1K  0 part
└─sda5   8:5    0   7,9G  0 part [SWAP]
sdb      8:16   0 298,1G  0 disk
├─sdb1   8:17   0 290,2G  0 part /media/karl/Ekstern 1
├─sdb2   8:18   0     1K  0 part
└─sdb5   8:21   0   7,9G  0 part
sdg      8:96   0   1,8T  0 disk
└─sdg1   8:97   0   1,8T  0 part /media/karl/170621F10CDB89B8

Den problematiske disk er den nederste.
Da den afmonterede var den helt væk fra oversigten - også fra / dev. Disken kørte stadig, men lampen i dockingen var slukket.
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: Opsætning af ekstern harddisk

Indlæg af thj01 »

Jeg tror ærlig talt det er noget langt mere grundlæggende der sker ... nemlig en form for strømbesparelsesfunktion. Den kan ligge på selve USB-disken, BIOS niveau eller i OS

Hvis jeg var dig ville jeg prøve at mounte drevet manuelt bare for at se om der kommer samme problem:

Sæt USB'en i, og find ud af dens placering ved hjælp af lsblk

Afmonter drevet (her forudsat at det stadig er /dev/sdg1)

Kode: Vælg alt

sudo umount /dev/sdg1


Opret en mappe i dit eget hjem

Kode: Vælg alt

mkdir ~/testdisk


Monter USB drevet (her forudsat at det stadig er /dev/sdg1)

Kode: Vælg alt

mount -t ntfs-3g /dev/sdg1 ~/testdisk/ 


Prøv at kopiere og tilgå drevet. Tjek om det stadig slår fra.
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Det lykkes ikke. Lige så snart jeg giver unmount kommandoen mounter den igen osv.
Findes der ikke en grafisk brugerflade, som kan gøre det samme?
I øvrigt har jeg i eftermiddag sat disken til en notebook, som kører Lubuntu og der har ingen problemer været. Den har været tilsluttet i mange timer, så åbenbart er fejlen kun i forbindelse med min alm. maskine.
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opsætning af ekstern harddisk

Indlæg af AJenbo »

Prøv at køre et live system på din normale computer og se om problemet også er der.
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Opsætning af ekstern harddisk

Indlæg af karl »

Problemet er der også, når jeg kører et live system.
Men når jeg sætter disken til mine notebooks (Lubuntu, Mint), er der ingen problemer.
Men hvad betyder det?
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opsætning af ekstern harddisk

Indlæg af AJenbo »

Prøvede du med en live Mint/Lubuntu?

Det betyder nok at det er et problem med selve computeren.