Opdateringsfejl

Få hjælp til at sætte programmer eller funktioner op.
naucher
Indlæg: 359
Tilmeldt: 23. jan 2009, 21:14
IRC nickname: naucher
Geografisk sted: Aabenraa

Opdateringsfejl

Indlæg af naucher »

Min far på 80 år har fået en ny PC for et måneder siden, og på den har jeg installeret Ubuntu 14.04LTS

Nu viser den en fejl i panelet, der indikerer, at pakkehåndteringen fejler. (se vedhæftede billede)

Når jeg prøver at køre Synatic får jeg denne fejl:

Kode: Vælg alt

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_trusty-getdeb_apps_i18n_Translation-da
E: Pakkelisten eller statusfilen kunne ikke åbnes eller forstås.
E: _cache->open() failed, please report.


Nu er taget hjem igen, efter besøg hos min far, og har ikke sådan lige adgang til PC'en igen. Så jeres svar, og min respons på det, kan godt komme til at tage (relativt) lang tid ... blot som advarsel :roll:
Vedhæftede filer
ghjfahbe.png
ghjfahbe.png (53.21 KiB) Vist 313 gange
De bedste hilsner
Naucher

Begejstret Bruger
Lenovo Thinkpad L15 (årg. 2023) | 16,0 GB RAM | 400 GB disk || Ubuntu 23.10
Lenovo Thinkpad S540 (årg. 2014) | 8,0 GB RAM | 400 GB disk || Ubuntu 22.04LTS
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opdateringsfejl

Indlæg af AJenbo »

Kode: Vælg alt

sudo apt-get clean
naucher
Indlæg: 359
Tilmeldt: 23. jan 2009, 21:14
IRC nickname: naucher
Geografisk sted: Aabenraa

Re: Opdateringsfejl

Indlæg af naucher »

Hej igen

Det med sudo apt-get clean virkede desværre ikke :(
Der sker tilsyneladende ingenting ved den kommando!

Derefter prøvede jeg med sudo apt-get update, og fik bl.a. disse linjer til svar:

Kode: Vælg alt

Henter:39 http://security.ubuntu.com trusty-security/multiverse Translation-en [2.437 B]
Henter:40 http://security.ubuntu.com trusty-security/restricted Translation-en [3.206 B]
Henter:41 http://security.ubuntu.com trusty-security/universe Translation-en [71,6 kB]
Ignorerer http://archive.getdeb.net trusty-getdeb/apps Translation-da_DK       
Ignorerer http://archive.getdeb.net trusty-getdeb/apps Translation-da 
Ignorerer http://archive.getdeb.net trusty-getdeb/apps Translation-en
Hentede 4.797 kB på 8s (597 kB/s)                                             
Indlæser pakkelisterne... Fejl!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_trusty-getdeb_apps_i18n_Translation-da
E: Pakkelisterne eller statusfilen kunne ikke tolkes eller åbnes.

Så står den bare der, og kommer ikke videre.

Er der flere gode forslag til løsning?
De bedste hilsner
Naucher

Begejstret Bruger
Lenovo Thinkpad L15 (årg. 2023) | 16,0 GB RAM | 400 GB disk || Ubuntu 23.10
Lenovo Thinkpad S540 (årg. 2014) | 8,0 GB RAM | 400 GB disk || Ubuntu 22.04LTS
Brugeravatar
Christian.Arvai
Admin
Indlæg: 10724
Tilmeldt: 26. apr 2008, 19:27
IRC nickname: Christian_Arvai
Geografisk sted: Holeby - Lolland

Re: Opdateringsfejl

Indlæg af Christian.Arvai »

Hvad siger den til:

Kode: Vælg alt

sudo dpkg --configure -a && sudo apt-get autoremove && sudo apt-get update && sudo apt-get upgrade
Med venlig hilsen Christian

"We can only see a short distance ahead, but we can see plenty there that needs to be done." -- Alan Turing
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opdateringsfejl

Indlæg af AJenbo »

Kode: Vælg alt

sudo rm /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_trusty-getdeb_apps_i18n_Translation-da
naucher
Indlæg: 359
Tilmeldt: 23. jan 2009, 21:14
IRC nickname: naucher
Geografisk sted: Aabenraa

Re: Opdateringsfejl

Indlæg af naucher »

Det hjalp desværre ikke.
Jeg prøvede endda først at slette den fil, som Ajenbo foreslog for derefter (igen) at køre Arvais forslag.

Resultatet ser sådan ud:

Kode: Vælg alt

jorgen@HP-ProDesk:~$ sudo rm /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_trusty-getdeb_apps_i18n_Translation-da
jorgen@HP-ProDesk:~$ sudo dpkg --configure -a && sudo apt-get autoremove && sudo apt-get update && sudo apt-get upgrade
Indlæser pakkelisterne... Fejl!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_trusty-getdeb_apps_i18n_Translation-da%5fDK
E: Pakkelisterne eller statusfilen kunne ikke tolkes eller åbnes.
jorgen@HP-ProDesk:~$
De bedste hilsner
Naucher

Begejstret Bruger
Lenovo Thinkpad L15 (årg. 2023) | 16,0 GB RAM | 400 GB disk || Ubuntu 23.10
Lenovo Thinkpad S540 (årg. 2014) | 8,0 GB RAM | 400 GB disk || Ubuntu 22.04LTS
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Opdateringsfejl

Indlæg af AJenbo »

Der er vist flere filer med problemer:

Kode: Vælg alt

sudo rm /var/lib/apt/lists/*