Installation af canon LBP5050

Scannere, kameraer, printere, mus, tegneplader osv.
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Installation af canon LBP5050

Indlæg af Fut »

Jeg har prøvet at installere ovenstående printer ved at følge vejledningerne her men det virker ikke den vil ikke installere pakkerne
Jeg får hele tiden denne medelse: Afhængighed kan ikke opfyldes; gs-esp
Jeg kører med Ubuntu 11.04
Senest rettet af Fut 22. sep 2011, 20:19, rettet i alt 2 gange.
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installitation af canon LBP5050

Indlæg af AJenbo »

Du har glemt at skrive hvor "her" er.
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Re: Installitation af canon LBP5050

Indlæg af Fut »

her. er dette forum. det var dog en model 1120
Stra
Indlæg: 3105
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Installitation af canon LBP5050

Indlæg af Stra »

Tjek om du har denne pakke installeret
gsfonts

stra
stra
Bruger Ubuntu 22.04 og 22.10 + lubuntu 22.10
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Re: Installitation af canon LBP5050

Indlæg af Fut »

gsfonts er installeret.
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installitation af canon LBP5050

Indlæg af AJenbo »

Fut skrev:her. er dette forum. det var dog en model 1120

Hvor?
Stra
Indlæg: 3105
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Installitation af canon LBP5050

Indlæg af Stra »

hint

Canon LBPxxxx installations HowTo
LBPxxx er samme fremgangsmåde, men ændre i versionsnummer.

stra
stra
Bruger Ubuntu 22.04 og 22.10 + lubuntu 22.10
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Re: Installitation af canon LBP5050

Indlæg af Fut »

Stra
Indlæg: 3105
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Installitation af canon LBP5050

Indlæg af Stra »

Får du ikke mer besked end den du har skrevet i første indlæg?

Hvis ja, kopier hele beskeden herind. (der skulle gerne være noget med versionsnumre m.m.)

Stra
stra
Bruger Ubuntu 22.04 og 22.10 + lubuntu 22.10
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Re: Installitation af canon LBP5050

Indlæg af Fut »

Okay jeg har forsøgt længe med den anviste guide men kan ikke få den til at virke. den bliver ved med at vise første besked i softwarwcenter når jeg doppeltklikker på de to filer eller den skriver "no sutch file or direktory" når jeg forsøger at starte den i terminal så jeg har opgivet det i 11,4 og forsøger det på konens der har 10,10.

Det er ingen fidus. Når jeg dobbeltklikker på de to pakker får jeg følgende besked fra softwarecenter: Forkert arkitekttur "i386"

Hvis jeg bruger metode 2 får jeg det problem at det er en 64 version og der er kun to rpm filer der ikke vil gøre noget. (ja jeg ved ikke meget om ubuntu)
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installation af canon LBP5050

Indlæg af AJenbo »

Jeg skal beklage at jeg sådan spørg til hvad det er du hentyder til, men med over 13000 emner kan det være lidt svært at gennemskue og uden at kende detaljerne er det ikke let at give god hjælp.

Problemet er nok ikke så meget 11.04 som det at Canon ikke levere en 64bit driver til Debian (RPM er til Red Hat) baseret systemer.

Du kan prøve at installere 32bit udgaven, der er en rimelig chance for at det vil virke, med denne kommando:

Kode: Vælg alt

sudo dpkg -i --force-architecture cndrvcups-common_2.30-1_i386.deb
sudo dpkg -i --force-architecture cndrvcups-capt_2.30-1_i386.deb
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Re: Installation af canon LBP5050

Indlæg af Fut »

tja samme resultat:
dpkg: fejl under behandling af cndrvcups-common_2.30-1_i386.deb (--install):
kan ikke tilgå arkivet: Ingen sådan fil eller filkatalog
Der opstod fejl under behandlingen:
cndrvcups-common_2.30-1_i386.deb
Fut
Indlæg: 20
Tilmeldt: 19. aug 2010, 15:51
Geografisk sted: Stevns

Re: Installation af canon LBP5050

Indlæg af Fut »

hmmm. flyttede filerne og fik så denne meddelelse:
Gør klar til at erstatte cndrvcups-common 2.20-2 (med cndrvcups-common_2.30-1_i386.deb)...
Udpakker erstatning cndrvcups-common...
Sætter cndrvcups-common (2.30-1) op...
mumis@Mumis:~$ sudo dpkg -i --force-architecture cndrvcups-capt_2.30-1_i386.deb dpkg: advarsel: undertrykker problemet, fordi --force er givet:
pakkearkitekturen (i386) passer ikke til systemet (amd64)
(Læser database... 171436 filer og mapper aktuelt installeret.)
Gør klar til at erstatte cndrvcups-capt 2.20-2 (med cndrvcups-capt_2.30-1_i386.deb)...
Udpakker erstatning cndrvcups-capt...
dpkg: advarsel: kan ikke slette gammelt katalog '/usr/local/share': Filkataloget er ikke tomt
dpkg: advarsel: kan ikke slette gammelt katalog '/usr/local': Filkataloget er ikke tomt
dpkg: advarsel: kan ikke slette gammelt katalog '/usr/lib64/cups/backend': Filkataloget er ikke tomt
dpkg: advarsel: kan ikke slette gammelt katalog '/usr/lib64/cups/filter': Filkataloget er ikke tomt
dpkg: advarsel: kan ikke slette gammelt katalog '/usr/lib64/cups': Filkataloget er ikke tomt
Sætter cndrvcups-capt (2.30-1) op...
Behandler udløsere for ureadahead ...
mumis@Mumis:~$

Det jeg ikke kan forstå er at den skriver amd 64 for det er en intel processor.
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installation af canon LBP5050

Indlæg af AJenbo »

Fut skrev:kan ikke tilgå arkivet: Ingen sådan fil eller filkatalog

Det betyder at cndrvcups-common_2.30-1_i386.deb ikke er i den sti den sti du har givet. Du kan bruge kommandoen cd til at skifte mappe, eller du kan skrive stien før filnavnet. Du kan selvfølgelig også flytte filerne ud til den mappe hvor du køre kommandoen fra (sansynligvis hjemmemappen aka ~ ).

Kort sagt er de du får i din anden besked et ok til at du har installeret begge pakker.
Stra
Indlæg: 3105
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Installitation af canon LBP5050

Indlæg af Stra »

Den fejl du får er fordi din filarkitektur er 64bit (amd64) og anvisningen i tråden er til 32bit driver og du skal have 64bit driver til din maskine.

Det kan gøres ved at downloade dette script http://codebin.cotescu.com/canon/lbp_driver/CanonCAPTdriver.tar.gz

Efter at det er hentet, finder du det i Hentede filer, flytter filen over i din hjemmemappe.
Åbner og udpakker den med arkivhåndtering. (højreklik og vælg )

Herefter går du i terminal og skriver/kopier

Kode: Vælg alt

sudo ./canonLBP_install.sh LBP5050
og scriptet skulle installere driverene.

Du kan også åbne og udpakke det med det samme og derefter gå i terminalen.

taget herfra http://radu.cotescu.com/how-to-install-canon-lbp-printers-in-ubuntu/


stra
Senest rettet af Stra 22. sep 2011, 23:16, rettet i alt 2 gange.
stra
Bruger Ubuntu 22.04 og 22.10 + lubuntu 22.10