Sort skærm under opstart

Forum for support til grafik og lydkort.
Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Sort skærm under opstart

Indlægaf Blueeyez » 17. dec 2014, 18:12

Periodisk måske 1 gang i ugen, så starter min bærbar op med sort skærm.
Det sker lige inden Ubuntu opstarts baren og eneste løsning er at genstarte bærbaren manuelt og holde shift i bund og gå ind i recovery mode og køre dpkg. Derefter starter bærbaren op, men skal igen genstartes fordi grafikkortet skal "godkendes" eller noget.. kører med 1368x768 (720p) men nu er skærmen i 1080p, efter en genstart er den dog i 720p igen. Derudover kan man ikke ændre opløsningen. Der er kun 1920x1080, men efter genstart er alle opløsningerne der igen...

Er der en måde jeg kan finde mere om fejlen? Det ser meget ud til at være relateret til mit Intel hd 4600 grafikkort driver..
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm under opstart

Indlægaf AJenbo » 17. dec 2014, 18:53

Har maskinen Hybrid grafikkort?

Klaus Rasmussen
Admin
Indlæg: 4846
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Sort skærm under opstart

Indlægaf Klaus Rasmussen » 17. dec 2014, 19:04

Prøv Intels driver-installer:

Kode: Vælg alt

https://01.org/linuxgraphics/downloads
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Sort skærm under opstart

Indlægaf Blueeyez » 17. dec 2014, 20:31

Det er kun et intel hd4600 og en i3-4000 (intel hd 4600 bruger cpuens kræfter)

Har installeret driveren, men ved jo ikke foreløbigt om det vil virke..
Er der ikke nogle log filer i Ubuntu?
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

Klaus Rasmussen
Admin
Indlæg: 4846
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Sort skærm under opstart

Indlægaf Klaus Rasmussen » 17. dec 2014, 20:41

Flytter lige tråden til grafik og lyd.
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Sort skærm under opstart

Indlægaf zob » 17. dec 2014, 20:45

Blueeyez skrev:Er der ikke nogle log filer i Ubuntu?

Kode: Vælg alt

/var/log/
og

Kode: Vælg alt

/var/crash/

Du kan også trykke på SUPER og skrive log i DASH, så kan du se den indbyggede logfilsfremviser. I den kan du søge med CTRL+F

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Sort skærm under opstart

Indlægaf Blueeyez » 17. dec 2014, 20:51

hmm er i /var/log/upstart men synes ikke lige det giver mening.. :S
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Sort skærm under opstart

Indlægaf zob » 17. dec 2014, 21:05

Jeg ved heller ikke om upstart er det rigtige sted at være.
Jeg tror måske du vil få mere ud af dmesg (meget af det der står i /var/log/syslog)
Du kan f.eks. køre

Kode: Vælg alt

dmesg --level=err,warn
for at se error og warnings.

Muligvis skal du finde syslog fra den dag du ved din maskine crashed og undersøge den. Du kan f.eks. pipe en log til grep på denne måde.

Kode: Vælg alt

sudo cat /var/log/syslog | grep -i error
eller hvad du nu måtte have lyst til at søge på. Prøv også segfault, warning, i965 og meget, meget mere.

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Sort skærm under opstart

Indlægaf Blueeyez » 17. dec 2014, 21:11

eneste jeg får med: dmesg --level=err,warn
er UFW (Firewall i Ubuntu)

har prøvet med err kun og der får jeg intet..
Det skete i dag, men det sker sjældent (Som om det sker ugentligt når min SSD kører trim).. det er lige det eneste jeg kan sætte det op mod..
Der er ingen antydninger på at fejlen sker, men under opstart (periodisk og ikke ofte) er skærmen blot sort og så må jeg slukke min bærbar og starte den op og holde shift i bund og køre dpkg.. derefter kommer jeg i Ubuntu, men må genstarte før det virker korrekt (mht grafik opløsning)
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Sort skærm under opstart

Indlægaf zob » 17. dec 2014, 23:42

Jeg tvivler på at det har noget med trim at gøre, men det første du bør gøre hvis du har sådan en mistanke er at køre den, så kan du få syn for sagn:

Kode: Vælg alt

sudo fstrim -v /

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm under opstart

Indlægaf AJenbo » 18. dec 2014, 00:26

Blueeyez skrev:Det er kun et intel hd4600 og en i3-4000 (intel hd 4600 bruger cpuens kræfter)

Har installeret driveren, men ved jo ikke foreløbigt om det vil virke..
Er der ikke nogle log filer i Ubuntu?

Hvad er det for en driver du har installeret?

Nej hd 4600 bruger ikke cpuen men sider blot fysisk i den samme blok som cpu.

Du er ikke ved at løbe tør for plads.

Kan du få et billede ved at trykje ctrl+alt+f1

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Sort skærm under opstart

Indlægaf Blueeyez » 18. dec 2014, 10:54

kenneth@kenneth-W54-55SU1-SUW:~$ sudo fstrim -v /
[sudo] password for kenneth:
/: 100634374144 bytes were trimmed

Et billed? Af hvad? Jeg bruger intels 1.0.7 nu og nu er opstarten sådan lidt længere tid om det fordi skærmen slukker og tænder et par gange eller billedet gør (Lidt i tvivl)..

mht grafikkortet så står følgende på abook.dk under Z510:

Intel HD Graphics

Intels nye grafikløsning hvor selve grafikdelen er flyttet fra motherboardet til selve processoren. Fordelen er hurtigere grafik, mindre strømforbrug, hvilket resulterer i længere batteritid og mindre varmeudvikling.

EDIT: Driveren er hentet herfra: https://01.org/linuxgraphics/downloads
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

Klaus Rasmussen
Admin
Indlæg: 4846
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Sort skærm under opstart

Indlægaf Klaus Rasmussen » 18. dec 2014, 11:22

Det er ikke driveren du har hentet der, det er kun installeren. Du kan se driveren i Yderligere drivere.
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Sort skærm under opstart

Indlægaf zob » 18. dec 2014, 12:37

Hvis det sker så sjældent bliver du nok nødt til at skulle igennem nogle ældre logfiler end den seneste nye syslog eller dmesg. Du kan læse mere om logfiler her:
https://help.ubuntu.com/community/LinuxLogFiles
Der er mange gode ting at lære.
Det første svar på spørgsmålet her kan måske lede dig i retning af hvad der skrives i de forskellige log-filer.
http://askubuntu.com/questions/186276/where-are-all-the-major-log-files-located
Og et sidste link "for good measure":
https://www.digitalocean.com/community/tutorials/how-to-view-and-configure-linux-logs-on-ubuntu-and-centos

Husk at grep'pe på noget interessant i forhold til dit problem ellers er der log-læsning nok til resten af dine dage. Som sagt kunne i965 være interessant.
F.eks. får jeg næsten hver gang jeg starter chrome en segfault pga en fejl i intel driveren og en forkert håndtering af dette i chrome - rettet i version 40 beta (jeg ved det ikke er det samme problem du har, for du når jeg ikke at starte chrome). Denne fejl kan jeg se f.eks. her:

Kode: Vælg alt

cat /var/log/syslog.1 | grep -i i965

Kode: Vælg alt

Dec 17 15:48:03 lars-Latitude-E6420 kernel: [   73.197960] chrome[3453]: segfault at 1f8 ip 00007f98be7fb63f sp 00007fff5e0c4760 error 4 in i965_dri.so[7f98be4a8000+51c000]
Dec 17 15:48:06 lars-Latitude-E6420 kernel: [   75.774112] chrome[3567]: segfault at 1f8 ip 00007fddb60ba63f sp 00007fff680f1150 error 4 in i965_dri.so[7fddb5d67000+51c000]
Dec 17 15:48:06 lars-Latitude-E6420 kernel: [   76.016251] chrome[3594]: segfault at 1f8 ip 00007f10930de63f sp 00007fff0910dc60 error 4 in i965_dri.so[7f1092d8b000+51c000]
Dec 18 12:10:18 lars-Latitude-E6420 kernel: [   17.067943] chrome[3283]: segfault at 1f8 ip 00007f37ae28b63f sp 00007ffff5471a90 error 4 in i965_dri.so[7f37adf38000+51c000]
Dec 18 12:10:18 lars-Latitude-E6420 kernel: [   17.479353] chrome[3389]: segfault at 1f8 ip 00007fb2eb62e63f sp 00007fff62ec51d0 error 4 in i965_dri.so[7fb2eb2db000+51c000]
Dec 18 12:10:19 lars-Latitude-E6420 kernel: [   17.743242] chrome[3423]: segfault at 1f8 ip 00007f950131f63f sp 00007fffadf5fde0 error 4 in i965_dri.so[7f9500fcc000+51c000]

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Sort skærm under opstart

Indlægaf Blueeyez » 18. dec 2014, 12:55

Klaus Rasmussen skrev:Det er ikke driveren du har hentet der, det er kun installeren. Du kan se driveren i Yderligere drivere.


Der er ingen drivere under yderligere drivere?

zob skrev:Hvis det sker så sjældent bliver du nok nødt til at skulle igennem nogle ældre logfiler end den seneste nye syslog eller dmesg. Du kan læse mere om logfiler her:
https://help.ubuntu.com/community/LinuxLogFiles
Der er mange gode ting at lære.
Det første svar på spørgsmålet her kan måske lede dig i retning af hvad der skrives i de forskellige log-filer.
http://askubuntu.com/questions/186276/where-are-all-the-major-log-files-located
Og et sidste link "for good measure":
https://www.digitalocean.com/community/tutorials/how-to-view-and-configure-linux-logs-on-ubuntu-and-centos

Husk at grep'pe på noget interessant i forhold til dit problem ellers er der log-læsning nok til resten af dine dage. Som sagt kunne i965 være interessant.
F.eks. får jeg næsten hver gang jeg starter chrome en segfault pga en fejl i intel driveren og en forkert håndtering af dette i chrome - rettet i version 40 beta (jeg ved det ikke er det samme problem du har, for du når jeg ikke at starte chrome). Denne fejl kan jeg se f.eks. her:

Kode: Vælg alt

cat /var/log/syslog.1 | grep -i i965

Kode: Vælg alt

Dec 17 15:48:03 lars-Latitude-E6420 kernel: [   73.197960] chrome[3453]: segfault at 1f8 ip 00007f98be7fb63f sp 00007fff5e0c4760 error 4 in i965_dri.so[7f98be4a8000+51c000]
Dec 17 15:48:06 lars-Latitude-E6420 kernel: [   75.774112] chrome[3567]: segfault at 1f8 ip 00007fddb60ba63f sp 00007fff680f1150 error 4 in i965_dri.so[7fddb5d67000+51c000]
Dec 17 15:48:06 lars-Latitude-E6420 kernel: [   76.016251] chrome[3594]: segfault at 1f8 ip 00007f10930de63f sp 00007fff0910dc60 error 4 in i965_dri.so[7f1092d8b000+51c000]
Dec 18 12:10:18 lars-Latitude-E6420 kernel: [   17.067943] chrome[3283]: segfault at 1f8 ip 00007f37ae28b63f sp 00007ffff5471a90 error 4 in i965_dri.so[7f37adf38000+51c000]
Dec 18 12:10:18 lars-Latitude-E6420 kernel: [   17.479353] chrome[3389]: segfault at 1f8 ip 00007fb2eb62e63f sp 00007fff62ec51d0 error 4 in i965_dri.so[7fb2eb2db000+51c000]
Dec 18 12:10:19 lars-Latitude-E6420 kernel: [   17.743242] chrome[3423]: segfault at 1f8 ip 00007f950131f63f sp 00007fffadf5fde0 error 4 in i965_dri.so[7f9500fcc000+51c000]



Får ingen informationer når jeg kører samme kommando og min har os i965 (Fandt ud af via "sudo lshw -c video"

Fejlen opstod jo i går under en opstart.. Kan man se i en log for hvergang ens bærbar opstarter?
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster