X og Nvidia Geforce driver problem Emnet er løst

Forum for support til grafik og lydkort.
februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

X og Nvidia Geforce driver problem

Indlægaf februardrengen » 13. nov 2014, 20:12

Jeg har flg problem:
Har installeret Ubuntu (unicorn) på min selvbyg computer med Nividia GeForce GTX 750 ti... har KUN ubuntu og igen Windows installation... min skærmopløsning kan max pt understøtte 1024 X 768 med den med Ubuntu installerede skærm driver, men understøtter i virkeligheden meget mere... har derfor hentet denne driver på Nvidias hjemmeside - NVIDIA-Linux-x86_64-340.58.run - har gjort den executabel og er gået i superuser mode ( sudo su - ) , men ved kørsel af fil får jeg besked om jeg skal lukke X.. for derefter at installere den (mere) info angiveligt på Nvidias hjemmeside under drivere, men jeg synes ikke jeg kan finde noget der..
Er der nogen der ved hvordan jeg afslutter installationen af driveren UDEN at X kører ?

Klaus Rasmussen
Admin
Indlæg: 4846
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: X og Nvidia Geforce driver problem

Indlægaf Klaus Rasmussen » 13. nov 2014, 20:15

Hej og velkommen til forum.

Der skal nok komme nogen og hjælpe dig, men jeg flytter lige tråden til grafik og lyd.

Har du set i systemindstillinger om der er yderligere drivere til dit skærmkort?
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 13. nov 2014, 20:18

nej hvordan gør man det ?

Klaus Rasmussen
Admin
Indlæg: 4846
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: X og Nvidia Geforce driver problem

Indlægaf Klaus Rasmussen » 13. nov 2014, 20:21

Tryk på tandhjulet øverst til højre og vælg systemindstillinger - vælg software og opdateringer - vælg sidste fane yderligere drivere. Lad den søge færdig.
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 13. nov 2014, 20:25

kan ikke lige finde den.. måske fordi jeg køre Mate desktop ?

fandt den .. den siger ingen yderliger driver blev fundet..

Klaus Rasmussen
Admin
Indlæg: 4846
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: X og Nvidia Geforce driver problem

Indlægaf Klaus Rasmussen » 13. nov 2014, 20:33

hvad hedder din Ubuntu helt precis? (filnavnet)
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 13. nov 2014, 20:37

Distributor ID: Ubuntu
Description: Ubuntu 14.10
Release: 14.10
Codename: utopic

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: X og Nvidia Geforce driver problem

Indlægaf zob » 13. nov 2014, 21:45

Hov. Det grafikkort har jeg også i min stationære her. Det fungerer ganske fint. Det er mærkeligt at den ikke tilbyder dig drivers.
Kan du ikke køre følgende. Det tager lige lidt længere end man tror. Den er først færdig når du igen har fået en prompt med en blinkende cursor.

Kode: Vælg alt

sudo lshw -c display && ubuntu-drivers devices

Copy-paste outputtet herind.

Hvordan har du forbundet? Med DVI kabel?

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 13. nov 2014, 23:56

den blinkede ikke, men ventede næsten fem minutter ;-)
jeg er forbundet med DVI og direkte i grafikkortets port..
her er outputtet:

*-display UNCLAIMED
description: VGA compatible controller
product: GM107 [GeForce GTX 750 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
tommy@shadow2014:~$

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: X og Nvidia Geforce driver problem

Indlægaf AJenbo » 14. nov 2014, 00:59

Det virker som om du ikke fik anden del med:

Kode: Vælg alt

ubuntu-drivers devices


Udmildbart ville jeg mene du fint skulle kunne installere Nvidia driveren, men hvor for den ikke forslår den virker noget underligt, du kan prøve at se om det virker selv at installere nvidia-331-updates

Generelt gør det sig gældende at man i Ubuntu ikke bør hente programmer fra nettet men i stedet installere dem via pakke arkivet.

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 14. nov 2014, 10:14

ok ja jeg vil også helst hente fra pakke arkivet

her er output af
"ubuntu-drivers devices"

tommy@shadow2014:~$ ubuntu-drivers devices
tommy@shadow2014:~$ sudo ubuntu-drivers devices
[sudo] password for tommy:
tommy@shadow2014:~$ sudo su -
root@shadow2014:~# ubuntu-drivers devices
root@shadow2014:~#

...først med su... derefter igen som sudo su -

Dernæst når jeg vil installere den foreslåede pakke siger den flg vil blive fjernet:

Nvidia cuda runtime library
libcuda1-304

Nvidia Legacy binary driver version 304
nvidia 304

Overgangspakke fra nvidia-current
nvidia current

Nvidia opencl icd
nvidia-opencl-icd-304

...skal jeg acceptere dette ?

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: X og Nvidia Geforce driver problem

Indlægaf AJenbo » 14. nov 2014, 11:14

"sudo su -" sætter gør dig til root hvor alle efterfølgende kommandoer bliver udført som root, når der blot er tale om en enkelt kommando er der ingen fordele ved den frem for sudo, og generelt bør det fra rådes at skifte til root da man kan komme til at skade systemet.

Det at "ubuntu-drivers devices" ikke finder nogen driver virker lidt mystisk.

Ja, det ser ud til at være rester fra en tidligere Ubuntu hvor du har haft en ældre Nvidia driver installeret. Måske er der sket en fejl under opgraderingen fra den tidligere Ubuntu, det kan være du er nød til at lave en ren installation.

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 14. nov 2014, 17:20

Jeg lærer noget nyt hver gang jeg er herinde - og rigtig mange tak for det :D
Harddisken var ren som en barnenumse da jeg fik den fra fabrikken/butikken... Ja jeg havde problemer under installationen... den "hang" i slutningen og måtte tvangs-rebootes...

Jeg vil gøre som du forslår og gen-installere.

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: X og Nvidia Geforce driver problem

Indlægaf AJenbo » 14. nov 2014, 17:39

Installerede du 14.10 som den første? Det virker mærkeligt for du har pakker liggende som kun burde være der hvis du har opgraderet fra en tidligere version

februardrengen
Indlæg: 69
Tilmeldt: 8. nov 2014, 16:55

Re: X og Nvidia Geforce driver problem

Indlægaf februardrengen » 14. nov 2014, 20:45

Hvis du med en "tidligere version" fx mener ubuntu 14.04 eller tidligere versioner, så nej... men hvis du mener dele af tidligere 14.10 installationer, så ja , der kan måske godt ligge "gamle" versioner da jeg har prøvet et par gange... Men det burde vel ikke være et problem når jeg vælger at alt overskrives ved hver installation?

Desværre gjorde en ny ren gen-installation ingen forskel.. skærm opløsningen kan stadig kun blive 1024 X 768...

"ubuntu-drivers devices" viser stadig ingenting... ej heller ikke kan jeg finde yderligere drivere når der søges.

Jeg spekulere i DVI kablet jeg har forbundet computeren til skærmen med kan være årsagen... der er en anden tilslutnings mulighed da der er et lidt større stik (kan ikke lige huske navnet), men det skal jeg så evt ud og købe.

Da det er min allerførste selvbyg pc er begynder-tvivlen også begyndt at melde sig.. har jeg connected alt korrekt da jeg samlede pc'en.. mangler jeg et kabel og burde mit spørgsmål egentlig ligge i hardware forummet.. ja jeg må indrømme at jeg er på bar bund :?

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster