HDMI Lyd

Forum for support til grafik og lydkort.
thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

HDMI Lyd

Indlægaf thj01 » 14. sep 2014, 21:01

Jeg får ingen lyd igennem mit HDMI kabel - men video delen fungerer..

aplay -l giver

Kode: Vælg alt

tj@thoj-Precision-M4800:~$ aplay -l
**** Liste over PLAYBACK-hardwareenheder ****
lydkort 0: HDMI [HDA Intel HDMI], enhed 3: HDMI 0 [HDMI 0]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 0: HDMI [HDA Intel HDMI], enhed 7: HDMI 1 [HDMI 1]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 0: HDMI [HDA Intel HDMI], enhed 8: HDMI 2 [HDMI 2]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 1: PCH [HDA Intel PCH], enhed 0: ALC3226 Analog [ALC3226 Analog]
  Underenheder: 1/1
  Underenhed #0: subdevice #0


Der er kun en "Speakers - Built in audio" tilgængelige i systemindstillingerne.


Der sidder et Nvidia Quadro kort i maskinen.
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: HDMI Lyd

Indlægaf lath » 14. sep 2014, 21:20

Hvilket styresystem?

I Ubuntu 14.04 LTS skulle HDMI virke ud af boksen - med radeon device driveren:
https://help.ubuntu.com/community/RadeonDriver#HDMI_Audio. Det er klart at den ikke virker med din GPU.

Du skulle måske kigge om der er en work-around for den device driver du bruger.

Jeg lagde mærke til at der for Radeon driveren står:
Ubuntu Precise/12.04 users should also note that they may need a newer kernel (>= 3.5.x) to enable HDMI audio on later cards.

... så en Linux box med et Nvidia grafikkort har måske også brug for en nyere kerne.

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: HDMI Lyd

Indlægaf zob » 14. sep 2014, 21:52

Som lath: Hvilket styresystem? Og dertil: hvilke drivere?
Uden at vide hvordan HDMI lyd helt fungerer, kunne jeg forestille mig at man skal bruge det properitære Nvidia drivere fra

Kode: Vælg alt

software-properties-gtk

AJenbo
Admin
Indlæg: 20524
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: HDMI Lyd

Indlægaf AJenbo » 15. sep 2014, 01:33

@Lath det er meget specefikt for radeon driveren.

@thj01
Det fungere for mig med den propritære, men husk at skifte lyd udgan under systemindstillinger efter du skifter særmudgang til hdmi

thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: HDMI Lyd

Indlægaf thj01 » 15. sep 2014, 15:07

I har ret - glemte helt alle de vigtige informationer

det er 14.04 LTS
NVidia Quadro k2100m

Der er anvendt nvidia driver 331.38 (den testede)

Der er ikke mulighed for at skifte lydudgang i systemindstillingerne.


Jeg har i dag prøvet at geninstallere, da jeg med alle mine driverforsøg og diverse krumspring havde formået at kvadre grafikdelen fuldstændig, så den kun kunne startes på i safe mode - og det har ikke hjulpet noget:(
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: HDMI Lyd

Indlægaf lath » 15. sep 2014, 15:26

thj01 skrev:I har ret - glemte helt alle de vigtige informationer

det er 14.04 LTS
NVidia Quadro k2100m

Der er anvendt nvidia driver 331.38 (den testede)

Der er ikke mulighed for at skifte lydudgang i systemindstillingerne.


Jeg har i dag prøvet at geninstallere, da jeg med alle mine driverforsøg og diverse krumspring havde formået at kvadre grafikdelen fuldstændig, så den kun kunne startes på i safe mode - og det har ikke hjulpet noget:(


Måske du kan bruge det her til noget?
[http://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/ (virker også for Ubuntu 14.04)
Hvis det er den der speech-dispatcher der har blame-bitten, så ligner det den samme situation vi havde engang om et softmodem der stjal output fra lydkortet (det er flere år siden).

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags

lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: HDMI Lyd

Indlægaf lath » 15. sep 2014, 15:30

Den her er for 12.04 men kan måske også bruges da det mest drejer sig om at have sat de rigtige indstillinger:
http://karuppuswamy.com/wordpress/2012/04/28/how-to-fix-nvidia-hdmi-audio-in-ubuntu-12-04/

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags

AJenbo
Admin
Indlæg: 20524
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: HDMI Lyd

Indlægaf AJenbo » 15. sep 2014, 21:16

Er der optimus i din maskine?

thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: HDMI Lyd

Indlægaf thj01 » 16. sep 2014, 13:09

@Lath

Jeg har prøvet dine guides... men det eneste jeg fik ud af alt det testeri var problemer med at starten Ubuntu op normalt. Grafikken virkede kun hvis jeg startede op i safemode bagefter :|. Men det skal lige siges at maskinen før dine råd også opførte sig underligt med grafikken - så det er ikke din skyld ;).

Så resultatet er at jeg har geninstalleret maskinen - fordi jeg vurderede det var det hurtigste at gøre fremfor at bruge tid på at søge internettet tyndt for løsningsmodeller. Men tak for henvisningerne.

@AJenbo

nej.....
http://www.laptopmag.com/reviews/laptops/dell-precision-m4800


Jeg har også fundet ud af at maskinen (DELL 4800) på arch linux' hjemmeside bl.a. bliver kritiseret for ikke at have lyd igennem HDMI porten.

****

Generelt så jeg blot være lykkelig for at det er en maskine arbejdet har leveret til mig og jeg ikke selv har betalt for den. For selvom den har nogle imponerende specifikationer og solid, så har den været et bøvlet bekendtskab hvad Linux angår

Jeg ved ihvertfald at næste gang jeg skal have en bærbar selv, så bliver det en maskine kun med Intel grafikkort og intel WIFI. Livet er simpelthen for kort til at bøvle med inkompatibelt hardware.
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: HDMI Lyd

Indlægaf thj01 » 19. sep 2014, 07:45

Nå resultatet er .... TADAAAAAAA

DELL M4800

SUCKS.......

Til nogle delelementer af Linux.........




Men hvis man skifter wifikortet (300,-) og ikke ønsker at køre lyd gennem HDMI.... så er det en genial fed, hurtig, skøn, dejlig maskine. Bliver mere og mere glad for at det er en arbejdsgiver maskine
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster