Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Forum for support til grafik og lydkort.
dragonbook
Indlæg: 29
Tilmeldt: 14. sep 2009, 13:07

Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Indlægaf dragonbook » 4. jun 2014, 12:40

Hej

Jeg er ved at skifte fra windows 7 til Xubuntu 14.04 på min eeebox 1501p som jeg udelukkende benytter som som mediabox til mit tv.

MEN... Hvordan bør jeg gribe dette an, GPU'en er en Nvidia ION der i windows 7 understøtter HW acceleration så den således nemt kan afspille Fuld HD film. Hvorledes opnår jeg nemmest dette i Xubuntu?

Jeg har forsøgt at sætte mig godt ind i det og kan læse at der findes en open source løsning der hedder vdpau-video, vil dette virke sammen med XBMC?

Eller skal jeg installere Proprietary Drivers fra Nvidia?

Nogen der ligger inde med gode råd til dette?

Det skal siges at jeg tidligere har forsøgt at få Proprietary Drivers til at virke sammen med XBMC i Lubuntu uden held.

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Indlægaf AJenbo » 4. jun 2014, 12:50

Lubuntu og Xubuntu er begge baseret på samme system så løsningen ville for begge være den samme.

Der er godt nok komponenter af VDPAU der er open source, men understøttelse skal være implementeret i driveren. Det er faktisk Nvidia der har udviklet VDPAU og den bedste understøttelse finder du med deres proprietære driver.

VDPAU er næsten altid den første form for HW acceleration en video implementere og så vidt jeg kan se har XBMC det også, det kan dog godt være det, ud over den proprietære driver, er nødvendigt at installere nogle hjælpe biblioteker, en hurtig Google søgning ser ud til at at indikere at man skal installere libvdpau1.

Du kan bruge vdpauinfo til at tjekke om VDPAU fungere på dit system.

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Indlægaf Blueeyez » 4. jun 2014, 14:08

Jeg ved godt dette nok er OT, men et alternativ kunne være en raspberry pi med Openelec (XBMC). Denne lille boks bruger under 10W og afspiller 1080p uden problemer. Der kan t ilkøbes Wifi dongle som virker uden videre..

Den største fordel ved denne løsning er at du måske kan rbuge fjerneynets fjernbetjening til og styre boksen. (Der er dog nogle fjernsyn dette ikke virker på, men det er sjældent at det sker.)

Derudover skal du have dine film over på en HDD/Nas eller andet som boksen kan læse fra.
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

dragonbook
Indlæg: 29
Tilmeldt: 14. sep 2009, 13:07

Re: Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Indlægaf dragonbook » 4. jun 2014, 14:11

AJenbo skrev:Lubuntu og Xubuntu er begge baseret på samme system så løsningen ville for begge være den samme.

Der er godt nok komponenter af VDPAU der er open source, men understøttelse skal være implementeret i driveren. Det er faktisk Nvidia der har udviklet VDPAU og den bedste understøttelse finder du med deres proprietære driver.

VDPAU er næsten altid den første form for HW acceleration en video implementere og så vidt jeg kan se har XBMC det også, det kan dog godt være det, ud over den proprietære driver, er nødvendigt at installere nogle hjælpe biblioteker, en hurtig Google søgning ser ud til at at indikere at man skal installere libvdpau1.

Du kan bruge vdpauinfo til at tjekke om VDPAU fungere på dit system.


Ok, jeg prøver det af så snart jeg kommer hjem. kendte ikke vdpauinfo, den må jeg prøve...

dragonbook
Indlæg: 29
Tilmeldt: 14. sep 2009, 13:07

Re: Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Indlægaf dragonbook » 4. jun 2014, 20:59

Så har jeg installere den sidste nye proprietære driver der er tilgængelig. Og i modsætning på Lubuntu så virker det i Xubuntu uden problemer. Jeg har nu fuld hw acceleration i XBMC :)

Mange tak for hjælpen :D

dragonbook
Indlæg: 29
Tilmeldt: 14. sep 2009, 13:07

Re: Hjælp til opsætning af Xubuntu + XBMC + HW acceleration

Indlægaf dragonbook » 7. jun 2014, 14:54

HW accelerationen virker som tidligere bemærket, men har nu opdaget at der hvert 1 minut kommer et kortvarig hold i afspilningen, dette sker ved afspilning af ethvert medie om det er i SD, HD eller full HD. Ja selv ved streamning.

Det sker også hvis jeg slår HW acceleration fra :?

Nogen der har en ide til hvad der kan være galt?

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster