Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Forum for support til grafik og lydkort.
Hvidemose
Indlæg: 85
Tilmeldt: 14. dec 2010, 18:34

Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Hvidemose » 10. nov 2013, 15:23

Hej

Jeg har en Asus u31s (bærbar) og bruger Ubuntu 13.10. Jeg prøver at finde ud af hvordan jeg bedst udnytter mit Nvidia gt 520 optimus grafik kort. Pt. tror jeg den bruger det indbyggede kort, altså det i bundkortet.

Jeg kan se, at der er flere forskellige muligheder, som sikkert gælder for forskellige systemsammensætninger. Men hvad er bedst at gøre i mit tilfælde. Skal jeg bruge Bumblebee eller er der en mere direkte måde med f.eks. nvidia drivere?

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf AJenbo » 10. nov 2013, 16:45

Nvidia understøtter ikke Optimus under Linux så du skal forsøge dig med en af de mere eksperimentelle løsninger

Hvidemose
Indlæg: 85
Tilmeldt: 14. dec 2010, 18:34

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Hvidemose » 10. nov 2013, 17:54

AJenbo skrev:Nvidia understøtter ikke Optimus under Linux så du skal forsøge dig med en af de mere eksperimentelle løsninger


Det var da særdeles fjollet at de fralægger sig denne opgave...

Hvad gør man så? Nogen der ved hvor godt bumblebee virker? Fandt dette link http://askubuntu.com/questions/258249/cant-figure-out-how-to-install-my-graphic-drivers-nvidia-gt-520m, Hvor det anbefales, at man gør dette:

I will assume you didn't install anything. In the terminal run:

Kode: Vælg alt

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update


If your card IS Optimus enabled run:

Kode: Vælg alt

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

Claus Henriksen
Forfatter
Indlæg: 783
Tilmeldt: 21. jan 2007, 17:45
Geografisk sted: Christianshavn

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Claus Henriksen » 11. nov 2013, 08:17

Vi har en lignende Asus hvor Bumblebee kører fint.
Claus Gårde Henriksen / Jeg bruger ikke Ubuntu / Debian Stable 9 DK

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf AJenbo » 11. nov 2013, 10:34

Så vidt jeg ved er det meget begrænset når det kommer til video acceleration

Claus Henriksen
Forfatter
Indlæg: 783
Tilmeldt: 21. jan 2007, 17:45
Geografisk sted: Christianshavn

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Claus Henriksen » 11. nov 2013, 22:11

@ajenbo: Det kan da godt være - er dette dårligt?

/home/ane> glxspheres
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2
60.933361 frames/sec - 68.001631 Mpixels/sec
59.820750 frames/sec - 66.759957 Mpixels/sec
59.836851 frames/sec - 66.777925 Mpixels/sec
59.838922 frames/sec - 66.780237 Mpixels/sec
/home/ane> optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 520M/PCIe/SSE2
83.960182 frames/sec - 93.699563 Mpixels/sec
85.084578 frames/sec - 94.954389 Mpixels/sec
85.183948 frames/sec - 95.065286 Mpixels/sec
85.412693 frames/sec - 95.320566 Mpixels/sec
83.982701 frames/sec - 93.724695 Mpixels/sec
/home/ane> vblank_mode=0 primusrun glxspheres
Polygons in scene: 62464
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2
156.968405 frames/sec - 175.176739 Mpixels/sec
141.587302 frames/sec - 158.011429 Mpixels/sec
141.959180 frames/sec - 158.426445 Mpixels/sec
141.885363 frames/sec - 158.344065 Mpixels/sec
Claus Gårde Henriksen / Jeg bruger ikke Ubuntu / Debian Stable 9 DK

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf AJenbo » 11. nov 2013, 22:29

Tænker på VDPAU, ved at Hvidemose var lidt indteraseret i om det hjælp med SilverLigt.

Hvidemose
Indlæg: 85
Tilmeldt: 14. dec 2010, 18:34

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Hvidemose » 12. nov 2013, 02:03

AJenbo skrev:Tænker på VDPAU, ved at Hvidemose var lidt indteraseret i om det hjælp med SilverLigt.


Egentlig ikke, vil bare gerne have det til at virke så godt som muligt.
Men jeg har dog et stort problem: Mit HDMI output virker slet ikke. Det gav billede før jeg installerede bumblebee, men der var det af meget dårlig kvalitet - men nu giver det ingen ting.

Nogen der ved hvordan jeg får mit HDMI til at virke?

pollute
Indlæg: 215
Tilmeldt: 29. okt 2009, 14:40
IRC nickname: pollute
Geografisk sted: Århus

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf pollute » 12. nov 2013, 08:49

Jeg har selv et GeForce GTX 550 Ti, og jeg bruger den Nvidia 319. Jeg kigger ikke så meget på ydelsen af grafik kortet, men alt virker umiddelbart. Jeg troede Bumblebee kun var til at spare strøm?

Hvordan finder i ud af om jeres grafik kort har Optimus. Jeg prøvede at kigge lidt igår, men uforgæves.
Min computer er en Acer Predator G3610

Ivan
Indlæg: 1133
Tilmeldt: 6. nov 2009, 17:05
Geografisk sted: Rudkøbing

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Ivan » 12. nov 2013, 09:00

Man starter med at kigge om det er et grafikkort til en notebook (laptop, bærbar kært barn har mange navne) hvis ikke, så har det svjks ikke optimus
http://www.nvidia.com/object/optimus_technology.html
Arch på Toshiba Satellite C660-1NT og Acer Aspire One 532h
Manjaro på hjemmerullet pc.

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf AJenbo » 12. nov 2013, 11:16

Hvis ubuntu selv forstår nvidia driveren har du ikke optimus. Problemet er at når man har optimus Starter maskinen med det svage kort (intel) så der for kan man få bedre ydelse ved at aktivere nvidia kortet.

Hvidemose
Indlæg: 85
Tilmeldt: 14. dec 2010, 18:34

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Hvidemose » 12. nov 2013, 13:21

Jeg er stadig på bagdelen med det her HDMI, som den overhovedet ikke fatter er sat i output. Jeg har set på forskellige muligheder, som virker mildest talt "out of my leauge", men man skal jo prøve at blive klogere/dummere en gang i mellem.

Er der nogen der ved om det kunne hjælpe at ændre "BUS id" på de to kort til det samme (inspireret af dette link: https://wiki.archlinux.org/index.php/Bumblebee#Multiple_monitors).

Kode: Vælg alt

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce GT 520M] (rev ff)

Jeg ville have prøvet (Og det er så det jeg mener med "out of my leauge", for jeg aner jo i virkeligheden ikke hvad konsekvensen ved denne ændring ville være, men dumdristig er man vel), men løb så ind i det problem, at jeg ikke har en fil som hedder /etc/X11/xorg.conf.

Men for at opsummere, kunne det være en mulighed?

AJenbo
Admin
Indlæg: 20525
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf AJenbo » 12. nov 2013, 13:30

Tilsyneladende burde det virke hvis HDMI også sider på Intel kortet. Ud fra det du har skrevet tror jeg at den gør det. Hvad mente du med at HDMI var i dårlig kvalitet?

Følgende burde oprette en xorg.conf, det vil så "hardcode" dit hardware så jo mere du fjerner fra den desto mere fleksibel vil dit system være:

Kode: Vælg alt

sudo Xorg :1 -configure
sudo cp /root/xorg.conf.new /etc/X11/xorg.conf

Hvidemose
Indlæg: 85
Tilmeldt: 14. dec 2010, 18:34

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Hvidemose » 12. nov 2013, 13:42

AJenbo skrev:Tilsyneladende burde det virke hvis HDMI også sider på Intel kortet. Ud fra det du har skrevet tror jeg at den gør det. Hvad mente du med at HDMI var i dårlig kvalitet?


Jamen sådan mere eller mindre forstyrende i farverne, men hvor man stadig kan se motivet. Det var faktisk det der var mit primære mål med at installere nvidiakortet.

Følgende burde oprette en xorg.conf, det vil så "hardcode" dit hardware så jo mere du fjerner fra den desto mere fleksibel vil dit system være:

Kode: Vælg alt

sudo Xorg :1 -configure
sudo cp /root/xorg.conf.new /etc/X11/xorg.conf



Ahh, sørens! - allerede ved første kommando sagde den:

Kode: Vælg alt

$ sudo Xorg :1 -configure
[sudo] password for whiteboy:

X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
Current Operating System: Linux whiteboy-U31SD 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.0-13-generic root=UUID=a278e673-dc2b-423e-8f3d-4eda2744154f ro quiet splash
Build Date: 15 October 2013  09:23:37AM
xorg-server 2:1.14.3-3ubuntu2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.30.2
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Nov 12 13:35:53 2013
setversion 1.4 failed
List of video drivers:
   savage
   siliconmotion
   vmware
   trident
   sisusb
   mach64
   mga
   sis
   openchrome
   neomagic
   qxl
   nouveau
   intel
   r128
   tdfx
   cirrus
   modesetting
   radeon
   s3
   ati
   fbdev
   vesa
(++) Using config file: "/home/whiteboy/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
(EE) Server terminated with error (2). Closing log file.


Hvad kan man så gøre?

Hvidemose
Indlæg: 85
Tilmeldt: 14. dec 2010, 18:34

Re: Hjælp til at anvende mit grafikkort (Nvidia - GT 520)

Indlægaf Hvidemose » 12. nov 2013, 14:51

Fejlen kommer i bunden:

Kode: Vælg alt

Number of created screens does not match number of detected devices.
  Configuration failed.
(EE) Server terminated with error (2). Closing log file.

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster