vrøvl med nvidia Emnet er løst

Forum for support til grafik og lydkort.
T-Duck
Indlæg: 214
Tilmeldt: 21. feb 2009, 10:49
Geografisk sted: Nord Falster

vrøvl med nvidia  Emnet er løst

Indlægaf T-Duck » 13. sep 2011, 09:42

Som mange andre med nvidia grafikkort så har jeg fået denne melding på fruens bærbar (You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.)
Men når jeg køre sudo nvidia-xconfig, og genstarter så går den i sort. Hvad kan jeg ellers gøre. For nu ville jeg prøve med unity igen
Packard bell EasyNote
Ubuntu 13.04 kde
Ram 8 GB ddr3
Intel Core i5 2. gen 2,3 GHz
640 GB HDD.
Nvidia GeForce GT 520M 1 GB
acer W700 tablet win8 64 bit

ActionpackedPIVII
Indlæg: 120
Tilmeldt: 11. apr 2009, 13:18
IRC nickname: steffen

Re: vrøvl med nvidia

Indlægaf ActionpackedPIVII » 13. sep 2011, 09:53

Kunne det tænkes at du bruger et "optimus" grafikkort. altså et hvor du både har et dedikeret nvidia grafikkort samt et intel kort?

Har selv fået den fejlmeddelelse hvis jeg i bios har sat grafikkortet til "optimus", hvilket ikke fungere i linux (ihvert fald ikke korrekt)

Derimod skal du vælge om du vil bruge nvidia kun eller kun intel.

T-Duck
Indlæg: 214
Tilmeldt: 21. feb 2009, 10:49
Geografisk sted: Nord Falster

Re: vrøvl med nvidia

Indlægaf T-Duck » 13. sep 2011, 09:55

JO det er det. Men det vil jeg prøve. det var i bios du sagde. det prøver jeg
Packard bell EasyNote
Ubuntu 13.04 kde
Ram 8 GB ddr3
Intel Core i5 2. gen 2,3 GHz
640 GB HDD.
Nvidia GeForce GT 520M 1 GB
acer W700 tablet win8 64 bit

T-Duck
Indlæg: 214
Tilmeldt: 21. feb 2009, 10:49
Geografisk sted: Nord Falster

Re: vrøvl med nvidia

Indlægaf T-Duck » 13. sep 2011, 10:02

T-Duck skrev:JO det er det. Men det vil jeg prøve. det var i bios du sagde. det prøver jeg

Jeg kan ikke vælge i bios
Packard bell EasyNote
Ubuntu 13.04 kde
Ram 8 GB ddr3
Intel Core i5 2. gen 2,3 GHz
640 GB HDD.
Nvidia GeForce GT 520M 1 GB
acer W700 tablet win8 64 bit

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: vrøvl med nvidia

Indlægaf AJenbo » 13. sep 2011, 10:46

Kode: Vælg alt

lspci -nn | grep -i vga

T-Duck
Indlæg: 214
Tilmeldt: 21. feb 2009, 10:49
Geografisk sted: Nord Falster

Re: vrøvl med nvidia

Indlægaf T-Duck » 13. sep 2011, 11:11

hvad så når den er skrevet. for der står:

duck@Holger:~$ lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:1050] (rev a1)
t-duck@Holger:~$
Packard bell EasyNote
Ubuntu 13.04 kde
Ram 8 GB ddr3
Intel Core i5 2. gen 2,3 GHz
640 GB HDD.
Nvidia GeForce GT 520M 1 GB
acer W700 tablet win8 64 bit

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: vrøvl med nvidia

Indlægaf AJenbo » 13. sep 2011, 11:51

Det siger mig at du har en Sandy Bridge cpu med indbygget grafikkort, hvilket så vidt jeg ved først er understøttet i 11.10. Det er muligt at du kan opgradere linux kernen og xorg i 11.04 og få det til at virke på den måde, men det kan godt give dig en masse besvær. Der er præsis 1 måned til 11.10 udkommer, så var jeg dig ville jeg nok bare vendte og så opgradere der.

Dit andet grafikort er NVIDIA GeForce GT 520M, men i optimus opsætning med et andet grafikkort skal det skrive til den andens framebuffer og det har Nvidia valgt ikke at undersøtte i deres Linux driver. Nouvou driveren har begyndende undersøttelse af det men det er stadig under udvikling.

bimsebasse
Indlæg: 296
Tilmeldt: 11. okt 2010, 16:25

Re: vrøvl med nvidia

Indlægaf bimsebasse » 13. sep 2011, 15:20

Jeg har også optimus og har opgivet at få det til at fungere optimalt i Linux, ser film i Windows.

Der er et par Optimus-til-Linux projekter du kan kigge på, Bumblebee og Ironhide.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: vrøvl med nvidia

Indlægaf AJenbo » 13. sep 2011, 15:28

bimsebasse skrev:Jeg har også optimus og har opgivet at få det til at fungere optimalt i Linux, ser film i Windows.

Er det andet kort ikke kraftigt nok til at se video på? Jeg ville da næsten tro det også er det der bliver brugt under Windows.

bimsebasse
Indlæg: 296
Tilmeldt: 11. okt 2010, 16:25

Re: vrøvl med nvidia

Indlægaf bimsebasse » 13. sep 2011, 16:49

Jeg har desværre ikke kunnet sætte den til kun at bruge Nvidia-kortet (kan jeg ikke fra bios på min, så det kan ikke gøres på den simple måde) uden at det har gjort opstartsprocessen eller grafikken mere buggy - men jeg ved heller ikke helt hvad jeg laver når jeg roder mig ud i den slags, må jeg indrømme.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: vrøvl med nvidia

Indlægaf AJenbo » 13. sep 2011, 17:40

bimsebasse skrev:Jeg har desværre ikke kunnet sætte den til kun at bruge Nvidia-kortet (kan jeg ikke fra bios på min, så det kan ikke gøres på den simple måde) uden at det har gjort opstartsprocessen eller grafikken mere buggy - men jeg ved heller ikke helt hvad jeg laver når jeg roder mig ud i den slags, må jeg indrømme.

Hvis du har Optimus har du ikke mulighed for at skifte i BIOS. Men det jeg siger er at dit Intel kort burde være kraftigt nok til at kunne køre videoer. Hvis det er Flash videoer så undersøtter Flash kun Nvidia og VIA driverene. Så her kan det muligvis være en løsning at bruge en anden af spiller.

ActionpackedPIVII
Indlæg: 120
Tilmeldt: 11. apr 2009, 13:18
IRC nickname: steffen

Re: vrøvl med nvidia

Indlægaf ActionpackedPIVII » 13. sep 2011, 20:16

Hmm. jeg har optimus og jeg kan vælge i BIOS.

For god ordens skyld vil jeg lige fortælle hvor jeg finder indstillingen henne.
For mig er den under config --> Display.
Her kan jeg så vælge "nvidia optimus", "Descrete graphics" (=nvidia only), "Integrated Graphics" (=intel grafik only)

Jeg får nøjagtig samme output ved hjælp af

Kode: Vælg alt

lspci -nn | grep -i vga


og her er det altså understøttet i ubuntu 11.04. Eller dvs. jeg kan ikke bruge "optimus" delen, men kan godt bruge processorens indbyggede grafikkort, ved kun at vælge "integrated graphics only" i bios. Og på samme måde kan jeg vælge "Descrete graphics only" og derefter installere den forslået nvidia driver og wupti, alt kører som hvis jeg kun havde et nvidia kort i maskinen.. Måske er jeg bare heldig at jeg kan vælge i min bios.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: vrøvl med nvidia

Indlægaf AJenbo » 13. sep 2011, 21:57

Det er lidt udsædvanligt da det at kunne vælge mellem kortne kræver en MUX og det nettop er det Optimus gør overflødig. Men det er selfvføllige også en fature den bærbar så har i modsætning til andre latops med Optimus.

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster