Ubuntu logger ikke almindeligt ind, men går i en slags DOS

Forum for support til grafik og lydkort.
asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Ubuntu logger ikke almindeligt ind, men går i en slags DOS

Indlægaf asgerlouis » 24. mar 2011, 12:32

Hej

Min ubuntuinstallation opfører sig mærkeligt. Jeg har lige installeret for et par dage siden, men nu, når jeg forsøger at logge ind, starter den ikke rigtigt ubuntu op. I stedet for viser den noget der ligner dos, altså sort baggrund med hvid skrift. Den efterspørger så mit brugernavn og password, som jeg så skriver ind, stadig i det doslignende skærmbillede. Så godtager den mit log in, og jeg befinder mig i min home mappe, men stadig i "DOS". For når jeg skriver dir i command feltet, giver den mig de mapper der ligger derinde.

Jeg aner ikke hvorfor den pludselig gør det? Måske skete det lig efter jeg opdaterede, det kan jeg ikke rigtigt huske. Hvis jeg prøvet at vælge den der form for fejlsikrede tilstand fra grub, så kan jeg godt komme ind på det der ligner det normale ubuntuskrivebord.

Hjælp - hvad skal jeg gøre?

PS: måske er det ikke det rigtige forum, i så fald flyt endelig min tråd til det rigtige sted.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf AJenbo » 24. mar 2011, 14:05

Det lyder som om der er problemer med grafik driveren, under Windows ville du have fået en blå skærm men i Ubuntu får du terminalen.

Hvilket grafikkort har du?

Kode: Vælg alt

lspci | grep VGA


Når du vælger fra listen i grub kan du så se en Ubuntu udgave med en ældre Linux kerne version? Prøv den og se om det afhjælper problemet.

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 24. mar 2011, 14:58

AJenbo skrev:Det lyder som om der er problemer med grafik driveren, under Windows ville du have fået en blå skærm men i Ubuntu får du terminalen.

Hvilket grafikkort har du?

Kode: Vælg alt

lspci | grep VGA


Når du vælger fra listen i grub kan du så se en Ubuntu udgave med en ældre Linux kerne version? Prøv den og se om det afhjælper problemet.


Ja, det kunne faktisk meget vel være grafikdriveren, for det var en jeg installerede efterfølgende, fra eksterne drivere eller hvad det nu hedder. Jeg er ikke hjemme lige nu så jeg kan ikke skrive kommandoen ind i terminalen, men mit kort hedder "geforce 310m". Er der problemer med det kort i forhold til ubuntu?

Jeg har prøvet de ældre versioner, som du foreslår, men det havde ingen effekt.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf AJenbo » 24. mar 2011, 16:30

Det er nok ikke ekstern hardware for det er tæt på umuligt at få et eksternt grafikkort, mon ikke du mener Yderliger hardware under system administration.
Kortet burde virke men det kunne godt virke som om Nvidia ikke rigtig tester deres mobile grafikkort for det ser altid ud til at være dem der fejler.
Se lige om denne guide ikke kan hjælpe, siden du allerede har installeret kan du skippe det første 2 billeder:
https://ubuntudanmark.dk/artikler/2011/01/13/nomodeset/

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 15:11

AJenbo skrev:Det er nok ikke ekstern hardware for det er tæt på umuligt at få et eksternt grafikkort, mon ikke du mener Yderliger hardware under system administration.
Kortet burde virke men det kunne godt virke som om Nvidia ikke rigtig tester deres mobile grafikkort for det ser altid ud til at være dem der fejler.
Se lige om denne guide ikke kan hjælpe, siden du allerede har installeret kan du skippe det første 2 billeder:
https://ubuntudanmark.dk/artikler/2011/01/13/nomodeset/


Jeg har prøvet guiden, men den ubuntu går stadigvæk til det der terminal-halløj du snakkede om. Altså, der sker ingen ændringer selvom jeg følger guiden.

Her har i informationer om mit grafikkort.

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2)
asger

Jeg håber der giver mening, og at problemet kan løses.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf AJenbo » 27. mar 2011, 16:27

Ok du har 2 grafikkort og det er sikkert det der volder dig problemet.

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 16:31

AJenbo skrev:Ok du har 2 grafikkort og det er sikkert det der volder dig problemet.


Nå, ja det er jo noget lort....men hvordan i alverden kan det ske? Og hvad kan jeg gøre?

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf AJenbo » 27. mar 2011, 16:32

For at få det til at virke skal du først gør det om som du gjorde i guiden.
Fjern nomodeset fra /etc/default/grub og kør:

Kode: Vælg alt

sudo update-grub


Så skal du afinstallere nvidia driveren:

Kode: Vælg alt

sudo apt-get purge nvidia-current


Til sidst vil det være en god ide at deaktivere det ekstra grafikkort i BIOS'en.

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 16:52

AJenbo skrev:For at få det til at virke skal du først gør det om som du gjorde i guiden.
Fjern nomodeset fra /etc/default/grub og kør:

Kode: Vælg alt

sudo update-grub


Så skal du afinstallere nvidia driveren:

Kode: Vælg alt

sudo apt-get purge nvidia-current


Til sidst vil det være en god ide at deaktivere det ekstra grafikkort i BIOS'en.


Okay, jeg prøver. Men jeg må også have nærmere hjælp til det med at fjerne kortet fra bios..

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 17:09

AJenbo skrev:For at få det til at virke skal du først gør det om som du gjorde i guiden.
Fjern nomodeset fra /etc/default/grub og kør:

Kode: Vælg alt

sudo update-grub


Så skal du afinstallere nvidia driveren:

Kode: Vælg alt

sudo apt-get purge nvidia-current


Til sidst vil det være en god ide at deaktivere det ekstra grafikkort i BIOS'en.


Jeg har gjort de to ting, men det var ikke noget ubuntu kunne lide. Når jeg forsøger at åbne ubuntu nu, så går computeren i står når den er i gang med at starte ubuntu. Jeg når til der, hvor den loader ubuntu og skærmen viser et ubuntu logo. Og når jeg forsøger at køre recovery, og så failsafe graphic mode (eller hvad det nu lige hedder), så kan jeg ikke engang det, fordi den kommer med fejlmeddelelser, og derefter fryser.

PS: alle de ændringer du har bedt mig lave, har jeg lavet i det der graphic fail safe mode....betyder det noget?

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf AJenbo » 27. mar 2011, 17:31

Nej det betyder ikke noget.
Jeg kan ikke hjælpe dig med bios da det er specefikt for din computer, du må enten de i manualen eller ringe til support.
Kan du skrive den fejl du får eller tage et billede af den så kan jeg bedere hjælpe.

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 17:48

Denne tredje gang, gik den fin i fail safe mode. Så det var jo godt

Til gengæld når jeg skriver lspci | grep VGA ind i terminalen, får jeg stadig denne besked:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2)

Hvilket vel stadigvæk betyder to grafikkort?

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf AJenbo » 27. mar 2011, 18:21

Ja, det er ikke døds nødvendig at du deaktivere geforce kortet, du må bar ikke installere Nvidia driveren til de (det er det du har gjort fra system-administration-yderligere driver).

Se om ikke det her er det der mangler:

Kode: Vælg alt

sudo rm /etc/X11/xorg.conf

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 18:26

Hey igen. Nu kan jeg så igen ikke benytte den seneste recovery, fordi den fryser i den menu, hvor man kan vælge failsafe og andre ting. Der kommer en form for lang kode frem, som står henover de forskellige valg jeg har. Det ser ikke autpriseret ud, dvs det ligner ikke en almindelig fejlmeddelelse, nærmere at der bare kommer noget tekst, fordi der er gået noget galt. Men her er i hvert fald de to "tekster" som er kommet frem.

(19.580934) phy0 -> rt2800pci_load_firmware: error - unstable hardware


og den anden tekst:

(13.5638261) phy0 -> rt2x00pci_regbusy_read: error indirect register acces failed: offset = 0x00007010, value=0xffffffff


Begge paranteser var firkantede, men dem kan jeg ikke lige lave.

Ved du hvad det betyder?

asgerlouis
Indlæg: 48
Tilmeldt: 22. feb 2009, 17:25
IRC nickname: styrmanden
Geografisk sted: Østerbro

Re: Ubuntu logger ikke almindeligt ind, men går i en slags D

Indlægaf asgerlouis » 27. mar 2011, 18:30

AJenbo skrev:Ja, det er ikke døds nødvendig at du deaktivere geforce kortet, du må bar ikke installere Nvidia driveren til de (det er det du har gjort fra system-administration-yderligere driver).

Se om ikke det her er det der mangler:

Kode: Vælg alt

sudo rm /etc/X11/xorg.conf



Yeay. Du havde ret - det var lige præcis det, der skulle til.

Mange mange tak for den vedholdene hjælp.

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 1 gæst