Problemer med 1080p Emnet er løst

Forum for support til grafik og lydkort.
Nissephar
Indlæg: 4
Tilmeldt: 19. feb 2011, 10:33

Problemer med 1080p

Indlægaf Nissephar » 19. feb 2011, 10:40

Hej alle

Jeg har et problem med at få min kammerats computer til at spille videoer i full HD optimalt. Den "hakker" meget i det. Jeg har forsøgt at installere VA API, men jeg har endnu ikke kunnet finde en guide, der får det til at virke. Det går galt når jeg skal køre kommandoen ./checkout-patch-build.sh
Jeg bruger som udgangspunkt denne guide:

http://www.splitted-desktop.com/~gbeauchesne/mplayer-vaapi/

Men mange andre minder rigtig meget om den.

Er der nogle af jer, der har andre fif?

Det skal dog lige nævnes, at jeg er bekymret for, at problemet er manglende hardwarekapacitet. Han siger dog, at den fint spillede full HD i windows... Jeg er dog ikke sikker på, at det ikke bare var 720p

Hilsen Lasse

Brugeravatar
NickyThomassen
Admin
Indlæg: 3650
Tilmeldt: 5. mar 2010, 19:58
IRC nickname: nicky
Geografisk sted: 192.168.20.42

Re: Problemer med 1080p

Indlægaf NickyThomassen » 19. feb 2011, 11:12

Hej Lasse og velkommen til forum

Afspilning har HD er desværre ikke helt så gnidningsløst i Ubuntu/Linux som man kunne ønske, men det plejer at være muligt at få det til at virke. Kender du de præcise specifikationer på computeren?

Ofte ligger problemet sig enten op af at CPU'en er delt op i 2 (eller flere) kerner, men kun bruger den ene til at afspille video, og da det kræver omkring 2ghz at afspille fuld HD (1080), så er én kerne ikke nok. Den anden del af problemet ligger i at få skærmkortet til at hjælpe med at spille HD, har du driverene for dit skærmkort installeret? Hvis ja, er det hardwareproducentens?

Hvis din computer er af nyere dato, så burde det være muligt at få HD til at virke ved "kun" at løse det ene problem. F.eks. kan jeg anbefale at du prøver og se HD'en med afspilleren "mplayer", den ligger i softwarearkivet. mplayer kan godt være lidt tricky at bruge, så hvis du prøver den er det værd at installere SMPlayer også, som er en komplet grafisk brugergrænseflade til mplayer.

Hilsen Nicky

Brugeravatar
NickyThomassen
Admin
Indlæg: 3650
Tilmeldt: 5. mar 2010, 19:58
IRC nickname: nicky
Geografisk sted: 192.168.20.42

Re: Problemer med 1080p

Indlægaf NickyThomassen » 19. feb 2011, 11:48

Jeg skulle selvfølgelig have kigget på det link du gav inden jeg skrev et svar, mplayer er nemlig en rigtig god afspiller. Normalt kan det dog bedst betale sig at installere software fra Softwarearkivet, men i tilfældet med mplayeren vil jeg mene at det kommer det an på CPU-typen.

Har du en Core Duo (2 kerner) eller en Core Quadro (4 kerner), så vil man få meget mere ud af mplayer hvis man bygger den til at understøtte det antal kerner man har til rådighed. Hvad version af Ubuntu bruger du?

Alternativt er der måske en af forrummets læsere der ved om man kan hente mplayeren et sted til at understøtte f.eks. 2 kerner. Jeg syntes ikke at jeg kunne finde andet en den almindelige udgave i Softwarearkivet.

Hilsen Nicky

Nissephar
Indlæg: 4
Tilmeldt: 19. feb 2011, 10:33

Re: Problemer med 1080p

Indlægaf Nissephar » 19. feb 2011, 12:54

Hej Nicky

Tak for dit hurtige svar.

CPU'en er Core2 Duo med en clockfrekvens på 1,50 GHz. Grafikkortet er et onboard GM965/GL960 fra Intel.
Ubuntu er 10.04 LTS

Jeg håber, at det er information nok til at komme med yderligere tips.

/Lasse

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Problemer med 1080p

Indlægaf AJenbo » 19. feb 2011, 16:52

Prøv om den køre med VLC, hvad format er videoen i, der findes nogle formater der er langt tunere en andre.

Nissephar
Indlæg: 4
Tilmeldt: 19. feb 2011, 10:33

Re: Problemer med 1080p

Indlægaf Nissephar » 19. feb 2011, 19:59

Filen afspilles også meget dårligt i vlc...

Det er en mkv fil

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Problemer med 1080p

Indlægaf AJenbo » 19. feb 2011, 23:12

Kan du ikke prøve at se i VLC hvilket format selve videon ligger i (MKV er bare n kontainer)

Brugeravatar
NickyThomassen
Admin
Indlæg: 3650
Tilmeldt: 5. mar 2010, 19:58
IRC nickname: nicky
Geografisk sted: 192.168.20.42

Re: Problemer med 1080p  Emnet er løst

Indlægaf NickyThomassen » 20. feb 2011, 10:26

Jeg har prøvet at finde de præcise minimumskrav til at afspille fuld HD på en PC, men af en eller anden grund er grænsen flydende. Det bedste jeg kunne finde ud af er at ved ren CPU-afvikling har man brug for 4000-6000mhz i én kerne, eller 2500-3000mhz i to kerner osv. Understøtter grafikkortet derimod det codec man bruger til at afvikle HD med, så ser det ud til at minimumskravene for CPU'en bliver halveret, og så burde to kerner af 1500mhz nok kunne afvikle fuld HD. Kravene for 720-HD tjekkede jeg ikke, men de er væsentligt lavere (så vidt jeg kunne se, så er de omkring 4 gange lavere).

For skærmkortet gælder at hvis CPU'en er hurtig nok til at afvikle HD'en, så skal kortet mere eller mindre bare kunne vise billedet på skærmen. Mange nyere kort, jeg kunne ikke finde ud af om det også gælder det der sidder i din computer, kan afvikle x264-codec'et direkte på en chip på kortet (hardware-afvikling), og sænker altså minimumskravet til CPU'en med omkring de 50% jeg nævnte højere oppe.

Det var teorien, så til det praktiske :)
Som AJ forslog, så ville det være rart at vide hvad de mkv'er du prøver at afspille er kodet med. Det ville absolut være en fordel hvis det er x264-codec'et da både codec-pakken (ffmpeg) og mplayeren kører rigtig godt med netop det codec, og hvis dit skærmkort er hardware-accelereret, så er det sikkert til det codec.

Jeg har kigget lidt nærmere på den udgave af mplayeren du prøver at bygge, og selvom at det (nok) ville være en fordel at få VA's API til at virke, så har den udgave af mplayer en ulempe: Den bliver bygget til kun at understøtte én kerne. Om API'en så er bedre end to kerner ved jeg ikke, men jeg har på fornemmelsen at det er lettere at installere 2-kerne udgaven af mplayeren, end API-patchen. Medmindre selvfølgelig, har du tjekket at mplayeren og ffmpeg begge var installeret da du prøvede patchen? Og hvad fejl kom den med i terminalen når du prøvede at tilføje patchen? Den række af kommandoer der skal køres for at installere patchen, er:

Kode: Vælg alt

sudo apt-get build-dep mplayer

(Denne kommando installere alt det der skal bruges til at bygge mplayeren og mplayeren (den tager nok lidt tid at køre...), bagefter skal du tjekke at fmpeg er installeret)

Kode: Vælg alt

sudo apt-get install ffmpeg

(Hvis den er installeret, så siger den det, og afslutter)
Så skal du skifte til til den mappe hvor den downloadede udgave af mplayeren ligger, med f.eks.

Kode: Vælg alt

cd Skrivebord/mplayer-vaapi-20110127/

Også køre scriptet med

Kode: Vælg alt

sudo sh checkout-patch-build.sh


Hvis ikke at det virker, kan du så ikke skrive fejlen her, og alt efter hvorfor det evt. ikke virker, så kan vi prøve at installere 2-kerne udgaven i stedet for.

Hilsen Nicky

Nissephar
Indlæg: 4
Tilmeldt: 19. feb 2011, 10:33

Re: Problemer med 1080p

Indlægaf Nissephar » 21. feb 2011, 12:22

I skal alle have mange tak for hjælpen.

Min kammerat siger nu, at han ikke har kunnet afspille 1080p film på sin computer da den havde windows heller. Det var kun 720p. Jeg tror derfor ikke, at den kan komme til at gøre det helt perfekt. Det er i hvert fald begrænset, hvad jeg kan hjælpe med mere, da jeg ikke har hans computer ved mig mere.

Endnu en gang mange tak for hjælpen alle sammen. For at afslutte denne tråd angiver jeg det sidste indlæg som en løsning.

Jeg håber, at I er ligeså villige til at hjælpe, hvis jeg skulle få brug for hjælp en anden gang.

Hilsen Lasse

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Problemer med 1080p

Indlægaf AJenbo » 21. feb 2011, 16:02

Selvfølelige.

Brugeravatar
NickyThomassen
Admin
Indlæg: 3650
Tilmeldt: 5. mar 2010, 19:58
IRC nickname: nicky
Geografisk sted: 192.168.20.42

Re: Problemer med 1080p

Indlægaf NickyThomassen » 21. feb 2011, 22:12

Jamen selvtak og hvis du får brug for hjælp igen, så opretter du bare en tråd, og så håber vi det bedste :D

Hilsen Nicky

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 1 gæst