Hjælp til Rome total war

Dette er forummet for spil til Ubuntu. Få hjælp til spillene og få hjælp til at afvikle Windows-spillene i fx Wine.
Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Hjælp til Rome total war

Indlægaf Hyperfluxx » 11. jan 2011, 05:44

Hejsa, Jeg har de sidste par dage siddet og prøvet at få rome total war til at fungere, men desværre uden held og ud fra hvad jeg kan læse på nettet er jeg ikke den eneste der har problemer med spillet.

Desværre er der næsten uendeligt mange problem stillinger så jeg har ikke kunnet finde en løsning på netop mit problem.

Når jeg starter spillet op, bliver der loaded og så kommer der først en hvid skærm. Efter et minuts tid slukker den kortvarigt for så at blive vidst igen, men nu med noget udeffiner bart grafik i bunden af skærmen.

Efter at have pillet lidt er jeg kommet frem til at détte må være hoved menuen.

Indtil videre har jeg prøvet at gen-installere og efterfølgende ændre på opløsningen uden held.

Jeg håber nogen har et trick som vil afhjælpe mig problem

Mvh.

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 11. jan 2011, 10:32

Det ser desvære ikke ud til at køre særlig godt under Wine
http://appdb.winehq.org/objectManager.php?sClass=version&iId=4496

prøv i øvrigt at køre det via terminalen og se om der kommer nogle fejl beskeder.

Kode: Vælg alt

wine ~/.wine/drive_c/STI/TIL/SPIL/PROGRAM.exe

Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Re: Hjælp til Rome total war

Indlægaf Hyperfluxx » 11. jan 2011, 10:53

Nej desværre ikke, men jeg kan se at det trods alt er lykkedes andre at få det op at køre så nu krydser jeg fingre for det lykkedes her også.

Jeg ved ikke hvilken forskel det gør, men den hvide skærm synes at udeblive når jeg eksekvere filen fra terminalen og i stedet dukker der ny en sort skærm op, dog ingen menu.


fixme:ddraw:DirectDrawEnumerateExA flags 0x00000003 not handled
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
fixme:win:EnumDisplayDevicesW ((null),0,0x32db4c,0x00000000), stub!
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
fixme:win:EnumDisplayDevicesW ((null),0,0x32dd24,0x00000000), stub!
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x37d7d00,0x37d7c70): stub
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
fixme:win:EnumDisplayDevicesW ((null),0,0x32302c,0x00000000), stub!
fixme:d3d:swapchain_init Add OpenGL context recreation support to context_validate_onscreen_formats
fixme:d3d8:IDirect3DDevice8Impl_ResourceManagerDiscardBytes Byte count ignored.
fixme:d3d:state_clipping Clipping disabled, but ARB_depth_clamp isn't supported.
fixme:ddraw:DirectDrawEnumerateExA flags 0x00000003 not handled
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
fixme:win:EnumDisplayDevicesW ((null),0,0x3228f4,0x00000000), stub!
fixme:d3d8:IDirect3DDevice8Impl_ResourceManagerDiscardBytes Byte count ignored.
fixme:d3d8:IDirect3DDevice8Impl_ResourceManagerDiscardBytes Byte count ignored.
fixme:ddraw:DirectDrawEnumerateExA flags 0x00000003 not handled
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
fixme:win:EnumDisplayDevicesW ((null),0,0x322e58,0x00000000), stub!
err:seh:setup_exception_record stack overflow 1356 bytes in thread 0009 eip 7bc3d6be esp 00230de4 stack 0x230000-0x231000-0x330000

Det er hvad der dukker op. giver desværre ingen mening for mig.

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 11. jan 2011, 11:06

Ok jeg ser ikke noget kritisk i beskeden, selv om der er en masse advarsler omkring graffiken. Kan det passe du har et Intel grafikkort?

Kode: Vælg alt

lspci | grep VGA

Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Re: Hjælp til Rome total war

Indlægaf Hyperfluxx » 11. jan 2011, 11:17

AJenbo skrev:Ok jeg ser ikke noget kritisk i beskeden, selv om der er en masse advarsler omkring graffiken. Kan det passe du har et Intel grafikkort?

Kode: Vælg alt

lspci | grep VGA


Det var da altid noget, men til dit spørgsmål så har Jeg googlet det til døde de sidste par timer uden at kunne finde noget specifik info omkring grafik kortet og packard bells hp vil ikke loade via mine browsere. Er der en funtion ligende den i windows hvor man kan se hardware info? ubuntu 10.10

Jeg kørte koden i terminalen uden nogen synderlig virkning, der kom hverken tekst eller andet.

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 11. jan 2011, 11:22

Ok det lyder lidt mystisk, kopierede du koden eller forsøgte du selv at indtaste den? Det er ikke et l i midten men en pipe (alt gr+', tasten ved siden af backspace), prøv at kopier koden. Hvis den stadig ikke virker så prøv at nøjes med at skrive lspci.

Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Re: Hjælp til Rome total war

Indlægaf Hyperfluxx » 11. jan 2011, 11:26

Jeg både kopierede og skrev den selv, men da jeg skrev Lspci fik jeg fælgende :


00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8132 Fast Ethernet (rev c0)

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 11. jan 2011, 11:49

Mobile Intel 945GME Express
Mystisk at den ikke kom op før.

Prøv at se om der findes opdateringer til spillet.

Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Re: Hjælp til Rome total war

Indlægaf Hyperfluxx » 11. jan 2011, 12:15

AJenbo skrev:Mobile Intel 945GME Express
Mystisk at den ikke kom op før.

Prøv at se om der findes opdateringer til spillet.


Kan det være manglende understøttelse af grafik kortet som er problemet ?

Der ér et par opdateringer til dertil og jeg har hentet dem, men wine vil ikke lade mig eksikvere dem på trods af jeg har tilføjet dem dertil. Nogen tanker herom eller en anden metode ?

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 11. jan 2011, 13:04

Driveren til dit grafikkort er temmelig solid så jeg tror ikke det er der problemet er. Hvordan tillader den dig ikke at køre opdateringerne?

Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Re: Hjælp til Rome total war

Indlægaf Hyperfluxx » 12. jan 2011, 11:22

Ok har du andre muligheder jeg kan afprøve ?

Det jeg mente var at jeg fik en meddelse om at filen ikke var eksikver bar, men det viste sig blot at være fordi jeg ikke gjorde det rigtigt og har fået det til at virke nu.

Opdateringen virkede dog ikke da den version jeg har ér fuldt opdateret.

Lidt ekstra info, hvis det kan hjælpe er at jeg både har prøvet at køre rtw og rtw barbarian invasion. Dertil spiller lyden iøvrigt som den skal når menuen, dvs den hvide skærm med udefinerbar grafik dukker op.

Jeg har læst et par andre tråde på andre fora hvor der er flere som skriver de har fået det til at virke under andre linux os og jeg overvejer derfor at afprøve et par stykker for at se hvis det skulle hjæple, men er det ikke samme version af wine som kører under alle linux versioner ?

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 12. jan 2011, 11:31

Wine opdateres hele tiden og der for er det ofte ikke samme version der følger mede forskellige udgaver. Installere du en ældre udgave af Ubuntu vil det også være med en ældre udgave af wine.
Det kunne godt lyde som om det er et problem med grafikkortet når du siger lyden virker. De fejl du fik var omkring en masse grafikfunktioner der ikke var understøttet og det kan jo godt resultere i af dele af billedet ikke er som det skal være.
Har du mulighed for at prøve på en anden maskine, eller ved du om der er et sted man kan hente og prøve en demo af spillet?

Hyperfluxx
Indlæg: 37
Tilmeldt: 16. okt 2010, 18:40

Re: Hjælp til Rome total war

Indlægaf Hyperfluxx » 12. jan 2011, 11:43

Det lyder jo umiddelbart til at være et kompabilitets problem mellem wine og mit grafik kort i modsætning til generel understøttelse under linux som jeg først antog. Er det muligt at afinstallere wine og så installere ældre versioner hvor understøttelsen måske fungere bedre ?

Nej jeg har desværre ikke mulighed for at afprøve det andre steder, den version jeg sidder med er en jeg har hentet på nettet da jeg sidder med en mini pc uden cdrom drev og dermed ikke har mulighed for at installere originalen.

Det kan selvfølgelig være dér problemet ligger, men før jeg skiftede os virkede det fint under windows

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Hjælp til Rome total war

Indlægaf AJenbo » 12. jan 2011, 14:41

Du kan opgradere til seneste veresion af Wine med følgende kommando:

Kode: Vælg alt

sudo apt-add-repository ppa:ubuntu-wine/ppa
sudo update
sudo upgrade

Tilbage til "Spil"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster