problemer med Intel 4965 agn 53-300 mbit.

Spørgsmål eller problemer med kablet netværk, trådløst netværk, netværkshåndteringen eller andet som vedrører netværk.
Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 13. dec 2008, 00:55

Hej

Jeg har lige installeret Ubuntu 8.10 64 bit igen. Efter at have forsøgt en masse ting for at få mit trådløse netværk til at virke.

Jeg har en 8 megabit forbindelse, men det kører kun med cirka 0,3 megabit.

Mit netkort er et Intel 4965 agn 53-300 mbit.


- Man kan downloade en Linux driver til den. Hvordan får man den til at virke.

- Jeg havde også downloadet en Windows driver, og et program til at køre det, men kan heller ikke få det til at virke.

- Jeg prøvede også at hente nogle programmer for at få det til at køre noget hurtigere. Det virkede heller ikke. Så hvad skal jeg gøre? Har i nogle gode ideer?

På forhånd tak for hjælpen.
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 13. dec 2008, 12:55

Man kan downloade en Linux driver til den. Hvordan får man den til at virke.

Hvis du kan være lidt mere specifik mht dine oplysninger, så er der større chance for at du kan få hjælp. Giv gerne et link til det sted, hvor du har downloadet linux-driveren fra - der står sikkert en anvisning på installationsproceduren, og hvis du finder den uforståelig så kan vi sikkert guide dig igennem.
havde også downloadet en Windows driver, og et program til at køre det, men kan heller ikke få det til at virke
- går ud fra at det er ndiswrapper du har prøvet at bruge. Her skal du bruge den rette drivers *.inf og *.sys filer. Har du dem kan vi også prøve ad den vej.
Jeg prøvede også at hente nogle programmer for at få det til at køre noget hurtigere
- hvilke programmer og hvorfra har du hentet dem? Normalt er det bedst at hente programmer fra ubuntus repositories (brug synaptic). Ikke at andre ikke vil virke, men det er ikke givet at de gør det.
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 13. dec 2008, 16:50

Her er der en der også har problemer.
Han kan heller ikke finde ud af at installere det, men det er vidst ikke i Ubuntu

http://www.linuxin.dk/node/12544.


Her er den driver jeg har downloadet
Og der er også en installationsvejledning, men det er næsten det rene volapyk for mig

http://intellinuxwireless.org/?p=iwlwifi&n=downloads
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 13. dec 2008, 17:12

Så vidt jeg kan se ved at google lidt, så burde der ikke være grund til at installere nogen særskilt driver til dit kort - understøttelsen skulle være integreret i linux-kernen siden version 2.6.23 - og 8.10 kører for øjeblikket på 2.6.27-9.
Men jeg kan forstå på dit første indlæg at du har en begrænset forbindelse - så kortet kan altså skabe forbindelse?
Så lad os prøve at se lidt oplysninger for om muligt at finde ud af, hvad der er galt.
Åbn en terminal og skriv:

Kode: Vælg alt

ifconfig

kopier output og post det her.
skriv også:

Kode: Vælg alt

iwconfig

kopier output og post det
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 13. dec 2008, 17:36

eth0 Link encap:Ethernet HWaddr 00:1d:92:4e:47:3e
UP BROADCAST MULTICAST MTU:576 Metric:1
RX packets:650446 errors:0 dropped:0 overruns:0 frame:0
TX packets:630863 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:263750588 (263.7 MB) TX bytes:138042780 (138.0 MB)
Interrupt:250 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:22 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1936 (1.9 KB) TX bytes:1936 (1.9 KB)

wlan0 Link encap:Ethernet HWaddr 00:21:5c:48:31:13
inet addr:192.168.2.165 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:576 Metric:1
RX packets:3051 errors:0 dropped:0 overruns:0 frame:0
TX packets:1381 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:451102 (451.1 KB) TX bytes:181434 (181.4 KB)

wmaster0 Link encap:UNSPEC HWaddr 00-21-5C-48-31-13-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)




lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"SMC"
Mode:Managed Frequency:2.412 GHz Access Point: 00:04:E2:D8:DB:D4
Bit Rate=11 Mb/s Tx-Power=14 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=100/100 Signal level:-33 dBm Noise level=-93 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.



Kan det bruges til noget?

Det skal lige siges at min kærestes bærbar der kører med Windows, der virker det trådløse internet fint. Så det må være min pc der fejler noget :-(
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 13. dec 2008, 20:14

Jeg går ud fra at du ikke har et kabel i din pc. Hvis du har - så tag det ud, og så må vi lige prøve at se hvad der sker, hvis vi deaktiverer de forskellige interfaces og så bringer wlan0 op igen.
Det interface som hedder lo skal du ikke røre ved - det er loopback, dvs. computerens forbindelse med sig selv.
Brug terminalen og skriv og udfør - en linje ad gangen:

Kode: Vælg alt

sudo ifdown wlan0
sudo ifdown pan0
sudo ifdown eth0
sudo ifdown wmaster0
sudo ifup wlan0

og prøv så at se om du har bedre forbindelse
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 13. dec 2008, 20:32

Lige for tiden har jeg et kabel i, men tager det selvfølgelig ud når jeg roder med tingene og skriver i terminalen. (Der er ikke meget idé i at have en bærbær så)

Jeg forstår ikke helt hvad du skiver, da jeg aldrig har rodet med det før, fordi det bare altid har virket.

Her er hvad der skete


paw@paw-laptop:~$ sudo ifdown wlan0
[sudo] password for paw:
Ignoring unknown interface wlan0=wlan0.
paw@paw-laptop:~$ sudo ifdown pan0
ifdown: interface pan0 not configured
paw@paw-laptop:~$ sudo ifdown eth0
ifdown: interface eth0 not configured
paw@paw-laptop:~$ sudo ifdown wmaster0
ifdown: interface wmaster0 not configured
paw@paw-laptop:~$ sudo ifup wlan0
Ignoring unknown interface wlan0=wlan0.
paw@paw-laptop:~$


Mit trådløse net er ikke blevet hurtigere. Træls.
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 13. dec 2008, 21:19

Uanset om du lige forstår det hele, så har du alligevel fået tastet de rigtige kommandoer ind. Og vi har så nu i hvert fald fået et par nyttige oplysninger.
Når dine interfaces er ukendte eller ikke-konfigurerede, så er der faktisk et problem med driveren.
Jeg kan desværre ikke lige være så meget med det næste døgns tid. Hvis der er andre som kan byde ind i mellemtiden kan du komme videre. Ellers vender jeg tilbage når der er mulighed for det.
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 13. dec 2008, 21:38

Okay. Foreløbig tak for hjælpen. Så må jeg se om der kommer andre for at hjælpe til.

Eller om jeg selv kan finde ud af et eller andet, men synes bare jeg har prøvet mange ting.
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 14. dec 2008, 22:53

Er der noget nyt i sagen? Hvis du kan evt kan komme med en opdatering så prøver jeg at tygge lidt på det i løbet af mandagen, så må vi se hvad der kan gøres.
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 14. dec 2008, 23:20

Der er ikke sket det store i sagen.

Jeg kan lige nævne at jeg burde hente med 500 kB/s, men henter kun med 20 kB/s (træls)
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 15. dec 2008, 00:03

Prøv lige at åbne en terminal og skriv:

Kode: Vælg alt

sudo ndiswrapper -l

og post outputtet.
Ligeledes med

Kode: Vælg alt

sudo lshw -C network
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 15. dec 2008, 00:20

Her er det.

paw@paw-laptop:~$ sudo ndiswrapper -l
sudo: ndiswrapper: command not found


paw@paw-laptop:~$ sudo lshw -C network
*-network
description: Wireless interface
product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: wmaster0
version: 61
serial: 00:21:5c:48:31:13
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yes driver=iwlagn ip=192.168.2.165 latency=0 module=iwlagn multicast=yes wireless=IEEE 802.11abgn
*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:05:00.0
logical name: eth0
version: 01
serial: 00:1d:92:4e:47:3e
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no module=r8169 multicast=yes port=twisted pair
*-network DISABLED
description: Ethernet interface
physical id: 1
logical name: pan0
serial: 06:ed:8c:79:42:5b
capabilities: ethernet physical
configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes


Kan det bruges til noget?
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf laoshi » 15. dec 2008, 08:45

Ja, der var et par oplysninger som jeg tror kan bruges. Lad os prøve flg.:

1: Gå ind i Programmer > Tilføj/fjern > skriv ndiswrapper i søgefeltet > installer 'Windows wireless drivers'

2:
Jeg havde også downloadet en Windows driver
- du skal have fat i driverens *.inf og *.sys filer. Dem lægger du i en mappe et sted hvor du kan finde dem.

3:Så åbner du System > Administration > Windows wireless drivers og installerer driveren derfra.

4:Så åbner du en terminal og skriver

Kode: Vælg alt

sudo ndiswrapper -m

for at loade modulet
herefter
sudo ndiswrapper -l

som gerne skulle give et svar om at driveren er installeret

5:Du kan også lige kontrollere din interfaces-fil. Den skulle gerne se ud som flg:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
auto wlan0
iface wlan0 inet dhcp
[osv for alle dine interfaces]

hvis ikke, så kan du redigere filen:

Kode: Vælg alt

gksu gedit /etc/network/interfaces

det giver dig en tekstbehandler med administrator-rettigheder.

6:Det vil så være nødvendigt at du genstarter netværket med

Kode: Vælg alt

sudo /etc/init.d/networking restart


Og så skulle det meget gerne være muligt for dig at koble op.

Lad høre hvordan det går.
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Phs80
Indlæg: 42
Tilmeldt: 10. dec 2008, 21:03
IRC nickname: Phs80
Geografisk sted: Vejle

Re: problemer med Intel 4965 agn 53-300 mbit.

Indlægaf Phs80 » 15. dec 2008, 21:05

Hej

1:Jeg har prøvet at downloade forskellige drivere fra,
http://downloadcenter.intel.com/Product ... uctID=2753
men kan ikke få nogen af dem til at virke.

Jeg har brugt Windows wireless drivers til at åbne windows driverne med.


1.5:Hvordan "installere" man linux driverne?


2:Når jeg skriver "sudo ndiswrapper -m" i terminalen kommer den frem med en masse linier hvor der står

module configuration already contains alias directive.


3:Min interface-fil ser således ud

paw@paw-laptop:~$ sudo ifdown wlan0
ifdown: interface wlan0 not configured
paw@paw-laptop:~$ sudo ifdown pan0
ifdown: interface pan0 not configured
paw@paw-laptop:~$ sudo ifdown eth0
ifdown: interface eth0 not configured
paw@paw-laptop:~$ sudo ifdown wmaster0
ifdown: interface wmaster0 not configured
paw@paw-laptop:~$ sudo ifup wlan0
Ignoring unknown interface wlan0=wlan0.

Det er da vist ikke helt rigtig


4:Hvad mener du med det her?

hvis ikke, så kan du redigere filen:
Kode:
gksu gedit /etc/network/interfaces

det giver dig en tekstbehandler med administrator-rettigheder.

Hvordan/hvad skal jeg rette?


5:Jeg kan læse på nettet at der er mange andre der også har problemer med dette kort.


6:Skal jeg virkelig til at køre Windows igen for at få det til at virke?


7:Når jeg går ind i Windows wireless drivers og trykker på Configure Network kommer den frem med denne fejlmeddelse

Could not find a network configuration tool


8:Lige nu jeg Ubuntu slet ikke finde det trødløse netværk.


9:Det blev dælme meget jeg fik skrevet, og måske en lille smule rodet.
Mybook M16 - 15.4" TFT Widescreen 1280 x 800 - Intel Core 2 Duo T7700 2.00 FSB800Mhz - 4 GB DDR2 RAM 667 MHz - 250 GB HDD SATA 7200RPM - Geforce 8600 GT 512 mb - Billede af en hund og en kat på ydersiden!!!! Samt en 7 år gammel stationær.

Tilbage til "Netværk"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster