[LØST] Wireless, BCM4318, automatisk aktiveret

Spørgsmål eller problemer med kablet netværk, trådløst netværk, netværkshåndteringen eller andet som vedrører netværk.
jokkefar
Indlæg: 16
Tilmeldt: 4. nov 2008, 22:34
IRC nickname: jokkefar

[LØST] Wireless, BCM4318, automatisk aktiveret

Indlægaf jokkefar » 5. nov 2008, 09:46

Det trådløse netværk fungerer upåklageligt på 8.10. Jeg skulle aktivere B43 driveren i Hardware Drivers, genstarte og hermed pingeling. :)

Der er ingen problemer med gnome-keyring eller sligt, men tilgengæld er netkortet automatisk deaktiveret efter hver koldstart, selvom Network Manager rapporterer at Wireless er 'Enabled'.

dmesg siger noget andet...

Ved at kalde:

Kode: Vælg alt

sudo echo 1 > /sys/devices/platform/acer-wmi/wireless


Herved får jeg lys i lampen og netværket tilslutter automatisk til mit WPA2 krypterede netværk. Det er da bare faens at jeg skal åbne en term og aktivere trådløst manuelt hver gang jeg åbner boxen, ik?

Hvordan slipper jeg smartest ud af det?

På forhånd tak,
Joakim
___________________________
Ubuntu 8.10, Acer Travelmate 4402LMi
Senest rettet af jokkefar 6. nov 2008, 14:50, rettet i alt 1 gang.

jokkefar
Indlæg: 16
Tilmeldt: 4. nov 2008, 22:34
IRC nickname: jokkefar

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf jokkefar » 6. nov 2008, 11:05

bump

Scrat
Indlæg: 127
Tilmeldt: 5. nov 2008, 12:28
Geografisk sted: Hvidovre

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf Scrat » 6. nov 2008, 11:15

Prøv at poste indholdet af filen

Kode: Vælg alt

/sys/devices/platform/acer-wmi/wireless
"This is Linux country. If you listen carefully, you can hear Windows reboot..."

Registered Linux user #133791 <|> http://counter.li.org
Registered Ubuntu user #24875 <|> http://ubuntucounter.geekosophical.net

jokkefar
Indlæg: 16
Tilmeldt: 4. nov 2008, 22:34
IRC nickname: jokkefar

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf jokkefar » 6. nov 2008, 13:34

Indholdet af wireless ved koldstart er altid 0 (og intet andet end 0), derfor kommandoen

Kode: Vælg alt

sudo echo 1 > wireless
Så tænder lampen og Network Manager forbinder til mit netværk.

Hvis det var muligt at ændre default til 1 ved opstart, så var der et problem mindre.

/Joakim

Scrat
Indlæg: 127
Tilmeldt: 5. nov 2008, 12:28
Geografisk sted: Hvidovre

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf Scrat » 6. nov 2008, 13:43

Det vil sige at det eneste filen indeholder er 0 ???

Har du prøvet at skrive 1 i filen ?
"This is Linux country. If you listen carefully, you can hear Windows reboot..."

Registered Linux user #133791 <|> http://counter.li.org
Registered Ubuntu user #24875 <|> http://ubuntucounter.geekosophical.net

Scrat
Indlæg: 127
Tilmeldt: 5. nov 2008, 12:28
Geografisk sted: Hvidovre

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf Scrat » 6. nov 2008, 13:47

Tryk Alt+F2 og skriv

Kode: Vælg alt

gedit .bashrc


Nederst i denne fil skriver du linien

Kode: Vælg alt

sudo echo 1 > /sys/devices/platform/acer-wmi/wireless


Log ud og ind igen.
"This is Linux country. If you listen carefully, you can hear Windows reboot..."

Registered Linux user #133791 <|> http://counter.li.org
Registered Ubuntu user #24875 <|> http://ubuntucounter.geekosophical.net

Scrat
Indlæg: 127
Tilmeldt: 5. nov 2008, 12:28
Geografisk sted: Hvidovre

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf Scrat » 6. nov 2008, 13:49

Først skal du selvfølgelig ændre rettigheden på filen /sys/devices/platform/acer-wmi/wireless.

Prøv dette

Kode: Vælg alt

sudo chown <dit brugernavn> /sys/devices/platform/acer-wmi/wireless
"This is Linux country. If you listen carefully, you can hear Windows reboot..."

Registered Linux user #133791 <|> http://counter.li.org
Registered Ubuntu user #24875 <|> http://ubuntucounter.geekosophical.net

mchro
Indlæg: 59
Tilmeldt: 18. jun 2008, 21:23
IRC nickname: shiyee
Geografisk sted: Aalborg, Denmark

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf mchro » 6. nov 2008, 13:51

En måde at gøre det på, er ihvertfald at indsætte linjen

Kode: Vælg alt

echo 1 > /sys/devices/platform/acer-wmi/wireless

i filen

Kode: Vælg alt

/etc/rc.local
, lige over linjen med

Kode: Vælg alt

exit 0


Ingen indstillinger ved "filen" bliver gemt, den oprettes på ny ved hver opstart (af kernen). Det er derfor ikke noget der kan rettes ved at ændre permissions eller owner eller noget.

Scrat
Indlæg: 127
Tilmeldt: 5. nov 2008, 12:28
Geografisk sted: Hvidovre

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf Scrat » 6. nov 2008, 13:54

mchro har ret ! :D
"This is Linux country. If you listen carefully, you can hear Windows reboot..."

Registered Linux user #133791 <|> http://counter.li.org
Registered Ubuntu user #24875 <|> http://ubuntucounter.geekosophical.net

jokkefar
Indlæg: 16
Tilmeldt: 4. nov 2008, 22:34
IRC nickname: jokkefar

Re: Wireless, BCM4318, automatisk aktiveret

Indlægaf jokkefar » 6. nov 2008, 14:45

Tak til mchro - det virker. Og tak til Scrat, også - alt fører til ny viden.

Jeg lurede lidt på en anden løsning, som måske også virker. Jeg vil oprette en fil, acer-wmi, i /etc/modprobe.d/ med følgende indhold

Kode: Vælg alt

options acer-wmi wireless=1


Men kan jeg det uden at køre

Kode: Vælg alt

sudo modprobe acer-wmi
???

Kode: Vælg alt

 dmesg |grep acer-wmi
[   16.130532] acer-wmi: Acer Laptop ACPI-WMI Extras
[   16.233773] Registered led device: acer-wmi::mail

Kode: Vælg alt

lsmod |grep acer
acer_wmi               18880  0
led_class              12164  2 acer_wmi,b43
wmi                    14504  1 acer_wmi

Mange tak!
/Joakim

Brugeravatar
Christian.Arvai
Admin
Indlæg: 10698
Tilmeldt: 26. apr 2008, 19:27
IRC nickname: Christian_Arvai
Geografisk sted: Holeby - Lolland

Re: [LØST] Wireless, BCM4318, automatisk aktiveret

Indlægaf Christian.Arvai » 20. dec 2008, 17:58

For at holde forum overskueligt, er emnet blevet flyttet til Netværk :)
.
MVH Redaktør-Team
Med venlig hilsen Christian

"We can only see a short distance ahead, but we can see plenty there that needs to be done." -- Alan Turing

Tilbage til "Netværk"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster