20.04 og SMB1

Få hjælp til at sætte programmer eller funktioner op.
gemu
Indlæg: 7
Tilmeldt: 6. maj 2020, 17:50

20.04 og SMB1

Indlægaf gemu » 25. aug 2020, 18:58

Hej!
Jeg har opgraderet til 20.04 og har derved mistet forbindelse til mine to NAS-servere (Windows-servere), som kræver SMB1.
Jeg har søgt på problemet og nu lært, at 20.04 ikke fungerer med SMB1.
Jeg har forsøgt at redigere i smb.conf-filen, men det er for kompliceret for mig som amatør lader det til.
Jeg har tilføjet "client min protokol = CORE" i global-sektionen. Men det gør ingen forskel.

(Det var mange sætninger med Jeg :)

Hvad kan/skal jeg gøre?

(begge NAS-servere er Dlink)

gemu

Klaus Rasmussen
Admin
Indlæg: 4819
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: 20.04 og SMB1

Indlægaf Klaus Rasmussen » 25. aug 2020, 19:16

Prøv at se denne:

https://askubuntu.com/questions/1229929/cant-acces-nas-anymore-after-upgrading-to-20-04?answertab=votes#tab-top

PS. Seneste version af Samba er version 4.12 fra 3-3-20!
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

AJenbo
Admin
Indlæg: 20519
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: 20.04 og SMB1

Indlægaf AJenbo » 25. aug 2020, 19:39

SMB1 er 34 år gammel, er det ikke muligt for dig at benytte en nyere udgave?

Seneste udgave af Windows 10 kan heller ikke tilgå SMB1 længere og Microsoft har frarådet dets brug siden 2014 da der er mange sikkerheds problemer med det.

gemu
Indlæg: 7
Tilmeldt: 6. maj 2020, 17:50

Re: 20.04 og SMB1

Indlægaf gemu » 26. aug 2020, 14:08

Tak Klaus og AJenbo!
Jeg har gjort det, Klaus har henvist til, men jeg får stadig følgende besked:
Kan ikke tilgå sted. Kunne ikke hente delingsliste fra server. Programmet forårsagede forbindelsesafbrud.
Jeg kan i Filer under Andre steder se, at begge servere eksisterer, og jeg kan se, at Windows-netværk mappen er tom.

AJenbo, min Windows-desktop kører Win10 og har kontakt til indholdet i begge NAS-servere.

Jeg har tjekket ændringen i smb.conf og fik følgende:
Unknown parameter encountered: "client min protokol", som den så ignorerer. (Jeg havde placeret linien 'client min protokol = NT1 i toppen af GLOBAL). Og den kommer også med en Warning: The 'netbios name' is too long (max. 15 chars).

Og i min rejse rundt i systemet finder jeg, at root-mappen har et hvidt x i et rødt mærke, der er ingen objekter, og der står, at ændringen er sket i går.

Hvad er der sket? Og hvad kan jeg gøre?

gemu

Klaus Rasmussen
Admin
Indlæg: 4819
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: 20.04 og SMB1

Indlægaf Klaus Rasmussen » 26. aug 2020, 15:44

Hvis du har haft fat i den vejledning selv, så prøv at fjerne denne ændring igen: (den virker selvmodsigende når du kører Samba 4.12)
client min protocol = SMB3 and client max protocol = SMB3 to /etc/samba/smb.conf

Restart samba og se om ikke det virker:

Kode: Vælg alt

sudo service smbd restart


Hvis ikke det virker har du så en fil: /etc/samba/smb.conf.bak ?
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 20.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

Tilbage til "Opsætning"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster