"Software index is broken" (Ubuntu 16.04)

Få hjælp til at sætte programmer eller funktioner op.
MortenHannibal
Indlæg: 3
Tilmeldt: 14. maj 2016, 12:40

"Software index is broken" (Ubuntu 16.04)

Indlægaf MortenHannibal » 14. maj 2016, 12:52

Jeg har installeret Ubuntu 16.04 på et helt friskt SSD drev.
Jeg søger hjælp til denne fejlmelding:

"Software index is broken

This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'."

De forslag, fejlmeldingen giver, har jeg forsøgt, men uden held.

De ender typisk i denne fejlmelding:

"morten@morten-E402SA:~$ sudo apt-get upgrade
[sudo] password for morten:
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Du kan muligvis rette dette ved at køre »apt-get -f install«.
Følgende pakker har uopfyldte afhængigheder:
liboxideqtcore0 : Afhængigheder: oxideqt-codecs (= 1.14.7-0ubuntu1) men den er ikke installeret eller
oxideqt-codecs-extra (= 1.14.7-0ubuntu1) men den er ikke installeret
liboxideqtquick0 : Afhængigheder: oxideqt-codecs (= 1.14.7-0ubuntu1) men den er ikke installeret eller
oxideqt-codecs-extra (= 1.14.7-0ubuntu1) men den er ikke installeret
E: Uopfyldte afhængigheder. Prøv med -f.
morten@morten-E402SA:~$ apt-get -f install
E: Kunne ikke åbne låsefilen /var/lib/dpkg/lock - open (13: Permission denied)
E: Kunne ikke låse administrationsmappen (/var/lib/dpkg/), er du rod (root)?"

En stakkels nybegynder som jeg er hjælpeløs her. Kan du hjælpe?
Senest rettet af MortenHannibal 16. maj 2016, 13:02, rettet i alt 1 gang.

Jimmyfj
Indlæg: 1712
Tilmeldt: 19. jul 2007, 19:35
Geografisk sted: Nordjylland

Re: Software index is broken (Ubuntu 16.04)

Indlægaf Jimmyfj » 14. maj 2016, 13:08

Glemte lige at skifte til root i en terminal, og der fik jeg samme fejl - Prøv at logge ind som root med

Kode: Vælg alt

sudo su


og så dit password

Du har glemt at bruge sudo i din sidste kommando

morten@morten-E402SA:~$ apt-get -f install
E: Kunne ikke åbne låsefilen /var/lib/dpkg/lock - open (13: Permission denied)
E: Kunne ikke låse administrationsmappen (/var/lib/dpkg/), er du rod (root)?


Edit:

Prøv med:

Kode: Vælg alt

sudo apt-get update --fix-missing
"OM 100 ÅR ER ALTING GLEMT !"


Ubuntu - Dev-ed.
Linux User # 448500

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Software index is broken (Ubuntu 16.04)

Indlægaf AJenbo » 14. maj 2016, 16:11

Hej og velkommen til forummet

De resultater du viser os er ikke med de kommandoer som systemet forslår. Ud fra de du har skrevet ser det dog ud til at du må have installeret et eller andet efter følgende fra ubuntu 16.04 da den melder om problemer omkring nogle browser komponenter der normalt ikke installeres med Ubuntu.


Prøve lidt at give os resultatet af dem i stedet:

Kode: Vælg alt

sudo apt-get update
sudo apt-get install -f


I modsætning til Jimmyfj vil jeg fraråde at køre "sudo su" da det kan lede en i uføre, husk i stedet at skrive sudo foran kommandoer hvor det er påkrævet, og kun når det er påkrævet.

Jeg tror også han fik skrevet den forkerte kommandoe til muligvis at løse problemet, det burde nok være:

Kode: Vælg alt

sudo apt-get upgrade --fix-missing

MortenHannibal
Indlæg: 3
Tilmeldt: 14. maj 2016, 12:40

Re: "Software index is broken" (Ubuntu 16.04)

Indlægaf MortenHannibal » 25. maj 2016, 15:51

Tusind tak for jeres hjælp :-)

MÅSKE er problemet løst... Jeg har 2 nye punkter.
1: Jeg har været i "Software & Updates" -> other software og der de-aktiveret begge tilfælde af "Canonical Partners".
2: Nu har jeg netop set jeres forslag, og har gjort, som foreslået. Og her er så resultatet: Det giver sikkert mere mening for jer, end for mig. Venter spændt på jeres reaktioner ;-)

Kode: Vælg alt

morten@morten-E402SA:~$ [b]sudo apt-get update[/b]
[sudo] password for morten:
Indlæser pakkelisterne... Færdig
morten@morten-E402SA:~$ [b]sudo apt-get install -f[/b]
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ       
Læser tilstandsoplysninger... Færdig
Følgende pakker blev installeret automatisk, og behøves ikke længere:
  ethtool libhud2 libqt5feedback5 libqt5multimedia5 libqt5organizer5
  libqt5quicktest5 libqt5test5 libubuntugestures5 libubuntutoolkit5
  libunity-action-qt1 libx86-1 plainbox-provider-checkbox
  plainbox-provider-resource-generic plainbox-secure-policy pm-utils
  pyotherside python3-checkbox-support python3-guacamole python3-jinja2
  python3-padme python3-plainbox python3-pyparsing python3-xlsxwriter
  qml-module-io-thp-pyotherside qml-module-qtfeedback
  qml-module-qtgraphicaleffects qml-module-qtquick-layouts
  qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qttest
  qml-module-ubuntu-components qml-module-ubuntu-layouts
  qml-module-ubuntu-performancemetrics qml-module-ubuntu-test qmlscene
  qtdeclarative5-dev-tools qtdeclarative5-test-plugin
  qtdeclarative5-ubuntu-ui-toolkit-plugin qtdeclarative5-unity-action-plugin
  suru-icon-theme ubuntu-mobile-icons ubuntu-ui-toolkit-theme vbetool
Brug »sudo apt autoremove« til at fjerne dem.
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
morten@morten-E402SA:~$ [b]sudo apt autoremove[/b]
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ       
Læser tilstandsoplysninger... Færdig
Følgende pakker vil blive AFINSTALLERET:
  ethtool libhud2 libqt5feedback5 libqt5multimedia5 libqt5organizer5
  libqt5quicktest5 libqt5test5 libubuntugestures5 libubuntutoolkit5
  libunity-action-qt1 libx86-1 plainbox-provider-checkbox
  plainbox-provider-resource-generic plainbox-secure-policy pm-utils
  pyotherside python3-checkbox-support python3-guacamole python3-jinja2
  python3-padme python3-plainbox python3-pyparsing python3-xlsxwriter
  qml-module-io-thp-pyotherside qml-module-qtfeedback
  qml-module-qtgraphicaleffects qml-module-qtquick-layouts
  qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qttest
  qml-module-ubuntu-components qml-module-ubuntu-layouts
  qml-module-ubuntu-performancemetrics qml-module-ubuntu-test qmlscene
  qtdeclarative5-dev-tools qtdeclarative5-test-plugin
  qtdeclarative5-ubuntu-ui-toolkit-plugin qtdeclarative5-unity-action-plugin
  suru-icon-theme ubuntu-mobile-icons ubuntu-ui-toolkit-theme vbetool
0 opgraderes, 0 nyinstalleres, 43 afinstalleres og 0 opgraderes ikke.
Efter denne handling, vil 50,1 MB diskplads blive frigjort.
Vil du fortsætte? [J/n] j
(Læser database ... 208218 filer og kataloger installeret i øjeblikket.)
Afinstallerer ethtool (1:4.5-1) ...
Afinstallerer qtdeclarative5-ubuntu-ui-toolkit-plugin (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer qml-module-ubuntu-test:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer qml-module-ubuntu-components:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer qtdeclarative5-unity-action-plugin:amd64 (1.1.0+14.04.20140304-0ubuntu2~gcc5.1) ...
Afinstallerer libunity-action-qt1:amd64 (1.1.0+14.04.20140304-0ubuntu2~gcc5.1) ...
Afinstallerer libhud2:amd64 (14.10+16.04.20160415-0ubuntu1) ...
Afinstallerer qml-module-qtfeedback:amd64 (5.0~git20130529-0ubuntu13) ...
Afinstallerer libqt5feedback5:amd64 (5.0~git20130529-0ubuntu13) ...
Afinstallerer libqt5multimedia5:amd64 (5.5.1-4ubuntu2) ...
Afinstallerer libqt5organizer5:amd64 (5.0~git20140515~29475884-0ubuntu20) ...
Afinstallerer qtdeclarative5-dev-tools (5.5.1-2ubuntu6) ...
Afinstallerer qtdeclarative5-test-plugin:amd64 (5.5.1-2ubuntu6) ...
Afinstallerer qml-module-qttest:amd64 (5.5.1-2ubuntu6) ...
Afinstallerer libqt5quicktest5:amd64 (5.5.1-2ubuntu6) ...
Afinstallerer libqt5test5:amd64 (5.5.1+dfsg-16ubuntu7) ...
Afinstallerer libubuntugestures5:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer libubuntutoolkit5:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer vbetool (1.1-3) ...
Afinstallerer libx86-1:amd64 (1.1+ds1-10) ...
Afinstallerer plainbox-provider-checkbox (0.25-1) ...
Afinstallerer plainbox-provider-resource-generic (0.23-1) ...
Afinstallerer python3-plainbox (0.25-1) ...
Afinstallerer plainbox-secure-policy (0.25-1) ...
Afinstallerer pm-utils (1.4.1-16) ...
Afinstallerer pyotherside (1.4.0-2) ...
Afinstallerer python3-checkbox-support (0.22-1) ...
Afinstallerer python3-guacamole (0.9.2-1) ...
Afinstallerer python3-jinja2 (2.8-1) ...
Afinstallerer python3-padme (1.1.1-2) ...
Afinstallerer python3-pyparsing (2.0.3+dfsg1-1) ...
Afinstallerer python3-xlsxwriter (0.7.3-1) ...
Afinstallerer qml-module-io-thp-pyotherside:amd64 (1.4.0-2) ...
Afinstallerer qml-module-qtgraphicaleffects:amd64 (5.5.1-1ubuntu1) ...
Afinstallerer qml-module-qtquick-layouts:amd64 (5.5.1-1ubuntu1) ...
Afinstallerer qml-module-qtquick-window2:amd64 (5.5.1-2ubuntu6) ...
Afinstallerer qml-module-qtquick2:amd64 (5.5.1-2ubuntu6) ...
Afinstallerer qml-module-ubuntu-layouts:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer qml-module-ubuntu-performancemetrics:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ...
Afinstallerer qmlscene (5.5.1-2ubuntu6) ...
Afinstallerer suru-icon-theme (14.04+16.04.20160415-0ubuntu1) ...
Afinstallerer ubuntu-mobile-icons (14.04+16.04.20160415-0ubuntu1) ...
Afinstallerer ubuntu-ui-toolkit-theme (1.3.1918+16.04.20160404-0ubuntu1) ...
Behandler udløsere for man-db (2.7.5-1) ...
Behandler udløsere for libc-bin (2.23-0ubuntu3) ...
Behandler udløsere for doc-base (0.10.7) ...
Processing 1 removed doc-base file...
morten@morten-E402SA:~$ [b]sudo apt-get upgrade --fix-missing[/b]
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ       
Læser tilstandsoplysninger... Færdig
Beregner opgraderingen... Færdig
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
morten@morten-E402SA:~$

Venlig hilsen
Morten

Jimmyfj
Indlæg: 1712
Tilmeldt: 19. jul 2007, 19:35
Geografisk sted: Nordjylland

Re: "Software index is broken" (Ubuntu 16.04)

Indlægaf Jimmyfj » 25. maj 2016, 16:14

Det ser ikke ud til at du har nogen updates der venter.

morten@morten-E402SA:~$ sudo apt-get upgrade --fix-missing
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Beregner opgraderingen... Færdig
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
"OM 100 ÅR ER ALTING GLEMT !"


Ubuntu - Dev-ed.
Linux User # 448500

Brugeravatar
Christian.Arvai
Admin
Indlæg: 10724
Tilmeldt: 26. apr 2008, 19:27
IRC nickname: Christian_Arvai
Geografisk sted: Holeby - Lolland

Re: "Software index is broken" (Ubuntu 16.04)

Indlægaf Christian.Arvai » 27. maj 2016, 00:20

Ifgl output er der blevet brugt kommandoer med tegn fra phpBB:

Kode: Vælg alt

morten@morten-E402SA:~$ [b]sudo apt-get install -f[/b]

Jeg går ud fra at, du efterfølgende ville markere kommandoerne med fed skrift, for at gøre det tydeligere at se hvor de blev brugt.

Det kan man godt ved brug af "Quote", men ikke ved "Code". Det er desuden aldrig en god ide at ændre på det output, da man ikke 100% kan forudsige hvor at de vigtige parter er (så havde man sandsynligvis selv løst fejlen).

Det er sådan set kun hvis at output indeholder fx IP, mailadd og lign. at man skal tænke på den slags :)

EDIT:
Husk at bruge "Code" til output - Det ser sjovt ud med "Quote":

Code:

Kode: Vælg alt

:)

Quote:
:)
Med venlig hilsen Christian

"We can only see a short distance ahead, but we can see plenty there that needs to be done." -- Alan Turing

Tilbage til "Opsætning"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster