Problem med Ubuntu/Windows dual boot på to harddiske Emnet er løst

Her kan du få hjælp til installationen af Ubuntu.
CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf CityTop » 2. feb 2007, 15:21

Fra en tidligere tråd:

CityTop skrev:
fr3ak skrev:Mener at der er flere folk rundt omkring som anbefaler at man installere win først og derefter linux. Det har noget med boot loaderen at gøre (GRUB), den overskriver nemlig MBR.

Ja, det er vist rigtigt. I hvert fald kunne jeg ikke længere boote med Ubuntu, da jeg først havde installeret Windows - selv om det skete på en separat harddisk. Nu er Ubuntu installeret forfra.


Jeg har fulgt dette: først er Windows installeret, og derefter Ubuntu. Men nu virker Windows-installationen ikke mere. Win er installeret på en separat harddisk, og der findes ikke længere nogen boot record. Da jeg installerede Ubuntu, fik jeg hda og hdb frem: jeg partitionerede hda til brug for Ubuntu, men rørte ikke NTFS-partitionen på hdb. Alligevel forlangte Ubuntu at jeg mountede noget til den partition, så jeg lavede en '/windows'. Hvad har jeg gjort galt? Jeg kan sagtens se filerne til Windows fra Gnome, men bootsektoren er tilsyneladende ødelagt.

mh
Peter

Balder
Indlæg: 732
Tilmeldt: 1. dec 2006, 20:44

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf Balder » 2. feb 2007, 17:47

Er det GRUB, der er forsvundet?
Mvh. - Balder

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Windows væk

Indlægaf CityTop » 2. feb 2007, 18:34

Nej, GRUB starter fint nok, men når jeg så trykker ESC og får menuen over tilgængelige systemer, der kan bootes, er Win XP væk.

/Peter

Ormen
Indlæg: 275
Tilmeldt: 6. dec 2006, 12:15
Geografisk sted: Trekantsområdet

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf Ormen » 2. feb 2007, 18:38

Jeg har været udsat for det samme, og forsøgte alle mulige ting for at få Win XP tilbage i GRUB. Intet lykkedes for mig, så det endte med at jeg installerede XP forfra igen. Denne gang var det dog min egen installation, og ikke firmaets sysadm der styrede showet.
Nu kører XP & Ubuntu fino på den samme disk. Hvad det er der har gjort at de ikke ville sammen skal jeg ikke kunne sige :?
/Ormen
Med en Ubuntu-overbevist svigermor!

Balder
Indlæg: 732
Tilmeldt: 1. dec 2006, 20:44

Re: Windows væk

Indlægaf Balder » 2. feb 2007, 19:28

CityTop skrev:... menuen over tilgængelige systemer, der kan bootes, er Win XP væk.


Ligger Windows heller ikke i: Filsystem/boot/grub/menu.lst..?
Mvh. - Balder

Ormen
Indlæg: 275
Tilmeldt: 6. dec 2006, 12:15
Geografisk sted: Trekantsområdet

Re: Windows væk

Indlægaf Ormen » 2. feb 2007, 19:33

Balder skrev:
CityTop skrev:... menuen over tilgængelige systemer, der kan bootes, er Win XP væk.


Ligger Windows heller ikke i: Filsystem/boot/grub/menu.lst..?


Det gjorde den ikke i mit tilfælde, og jeg søgte nettet tyndt for at finde ud af hvad man skulle skrive og gøre for at få tilføjet Windows til GRUB. Havde også en tråd herinde, men lige lidt hjalp det.. :cry:
/Ormen

Med en Ubuntu-overbevist svigermor!

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Re: Windows væk

Indlægaf CityTop » 3. feb 2007, 16:50

Balder skrev:Ligger Windows heller ikke i: Filsystem/boot/grub/menu.lst..?


Nej, Windows er ikke med i denne fil.

/Peter

Balder
Indlæg: 732
Tilmeldt: 1. dec 2006, 20:44

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf Balder » 3. feb 2007, 17:13

@ CityTop:

Og heller ikke i menu.lst_backup..?

Findes Windows dér kan du kopiere til menu.lst.

Det du skal have fat i ser hos mig således ud (regn ikke med at du kan anvende mine indstillinger):

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Windows NT/2000/XP (loader)
root (hd0,0)
savedefault
makeactive
chainloader +1


Læs evt. denne tråd.
Mvh. - Balder

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Virker ikke i grub prompt

Indlægaf CityTop » 3. feb 2007, 23:32

Balder skrev:Læs evt. denne tråd.


Jeg prøvede at gå ind i grub prompt'en ved boot og der skrive

Kode: Vælg alt

rootnoverify hd(1,0)

går jeg ud fra er rigtigt - jeg har Windows liggende på disk nr. 2
og så

Kode: Vælg alt

chainloader +1

og til sidst

Kode: Vælg alt

boot

Herefter får jeg "Starting up..." - men så sker der ikke mere :?

Balder skrev:Og heller ikke i menu.lst_backup..?

Den fil har jeg ikke, ser det ud til.

Balder
Indlæg: 732
Tilmeldt: 1. dec 2006, 20:44

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf Balder » 4. feb 2007, 00:11

Her er jeg også ude på tynd is, så følgende skal tages med et gran salt (et kilo salt).

Filen menu.lst_backup er selvsagt en backup af menu.lst, hvilket kan være rart at have og den dannes sådan her:

Terminal: sudo cp /boot/grub/menu.lst /boot/grub/menu.lst_backup

Og nu er det, at isen begynder at knage..:

Jeg tror at du skal redigere direkte i menu.lst ved simpelthen, nederst, at tilføje noget i retning af:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Windows NT/2000/XP (loader)
root (hd0,0)
savedefault
makeactive
chainloader +1


Med det rigtige disk- og partitionsnummer naturligvis. - Men der er altså ikke noget videnskabeligt belæg for denne antagelse...
Mvh. - Balder

Ormen
Indlæg: 275
Tilmeldt: 6. dec 2006, 12:15
Geografisk sted: Trekantsområdet

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf Ormen » 4. feb 2007, 00:52

Jeg har forsøgt tricket, og i utallige kombinationer uden held. Skal self. ikke sige at det ikke kan lade sig gøre, men uanset, så tag backupen! Til sidst slettede jeg indholdet i menu.lst i et desperat forsøg på at få den til at boote, men det hjalp ca. lige så meget som at slå til skærmen ;)
Men er der nogen vejledning i hvordan menu.lst input skal bygges op? Har forsøgt at google og søge på div. fora for det, men har ikke fundet en direkte opskrift eller dokumentation. Er der nogen der kender til noget sådanne?
/Ormen

Med en Ubuntu-overbevist svigermor!

Balder
Indlæg: 732
Tilmeldt: 1. dec 2006, 20:44

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf Balder » 4. feb 2007, 01:08

GRUB manual. Der kan læses om konfigurationsfilen til GRUB menuen - menu.lst - under 5 Configuration.
Mvh. - Balder

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Kommandoerne virker ikke i grub prompten

Indlægaf CityTop » 4. feb 2007, 11:50

Balder skrev:Filen menu.lst_backup er selvsagt en backup af menu.lst, hvilket kan være rart at have og den dannes sådan her:

Terminal: sudo cp /boot/grub/menu.lst /boot/grub/menu.lst_backup


Jeg forstår godt, det kan være en fin idé at have en backup af den fil, og det vil jeg også gerne lave. Tilbage står dog, at de kommandoer, der skal stå i Windows-delen af den fil, ikke virker, når man afvikler dem i grub prompten, som man får ved at trykke ESC inden Ubuntu starter med at boote, og derefter 'c', når boot-menuen kommer frem:

Kode: Vælg alt

rootnoverify (hd1,0)
chainloader +1
boot

((hd1,0) i mit tilfælde, fordi Windows ligger på harddisk nr. 2)

Jeg tror altså heller ikke, de kommandoer vil virke, hvis man indsætter dem i menu.lst, som vel egentlig er en slags script?

Men selvfølgelig: intet skal være uprøvet!

CityTop
Indlæg: 158
Tilmeldt: 18. jan 2007, 21:22
Geografisk sted: Bruxelles, Belgien

Problem med Ubuntu/Windows dual boot på to harddiske

Indlægaf CityTop » 4. feb 2007, 18:12

Ormen skrev:Jeg har været udsat for det samme, og forsøgte alle mulige ting for at få Win XP tilbage i GRUB. Intet lykkedes for mig, så det endte med at jeg installerede XP forfra igen. Denne gang var det dog min egen installation, og ikke firmaets sysadm der styrede showet.
Nu kører XP & Ubuntu fino på den samme disk. Hvad det er der har gjort at de ikke ville sammen skal jeg ikke kunne sige :?


Men vil det sige, at du installerede Windows efter Ubuntu - og fik det til at virke på den måde? Prøvede du at reparere den eksisterende Win XP-installation, før du installerede forfra?

Ormen
Indlæg: 275
Tilmeldt: 6. dec 2006, 12:15
Geografisk sted: Trekantsområdet

Problem med Ubuntu/Windows dual boot på to harddiske  Emnet er løst

Indlægaf Ormen » 4. feb 2007, 18:31

CityTop skrev:Men vil det sige, at du installerede Windows efter Ubuntu - og fik det til at virke på den måde? Prøvede du at reparere den eksisterende Win XP-installation, før du installerede forfra?


Da jeg geninstallerede Win, da slettede jeg hele disken, altså også min Ubuntu installation. Derefter installerede jeg Ubuntu og så virkede det. Jeg skal ikke sige om firmaets opsætning har været anderledes eller hvad der har gjort det, men uanset hvad , så er Windows hysterisk med andre styresystemer end sig selv :evil:
Jeg prøvede at reparere MBR med en windows installations cd, men da det heller ikke gav noget brugbart resultat, så gad jeg ikke bøvle mere med en amputeret installation, og derfor røg der helt nyt på :)
/Ormen

Med en Ubuntu-overbevist svigermor!

Tilbage til "Installation"

Hvem er online

Brugere der læser dette forum: [Crawler] og 1 gæst