Ubuntu 18.04.4 LTS hjælp

Her kan du få hjælp til installationen af Ubuntu.
AJenbo
Admin
Indlæg: 20519
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf AJenbo » 28. mar 2020, 19:42

nemes543 skrev:/dev/mmcblk0boot0 (skrivebeskyttet)
/dev/mmcblk0boot1 (skrivebeskyttet)

de to her på billed, er der lige meget om jeg formater disken, forbliver de der, jeg kan ikke låde dem op...

De er vist en del af den interne UEFI, men det er ikke dem der er din ESP hvis det er det du tænker. Tror ikke der er nogen grund til at rode med dem.

Igen prøv at lave en GPT/MBR tabel på mmcblk0, installer Ubuntu ren og vis os hvordan det ser ud (vi skal også vide om det er UEFI eller Legacy din bios er sat til). Så kan vi hjælpe dig med at installere GRUB manuelt.

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 28. mar 2020, 21:05

Så er den med windows 10 lavet om!
gpt.png
gpt.png (152.93 KiB) Vist 109 gange

sådan ser den ud inde install ubuntu!
partition.png
partition.png (48.42 KiB) Vist 109 gange

GPT.. men om jeg formater den eller ej er den GPT i windows 10 også?
disk.png
disk.png (77.76 KiB) Vist 109 gange

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 28. mar 2020, 21:05

sådan så disken ud fra windows inde jeg slettet alt.
kun windows.jpg
kun windows.jpg (152.42 KiB) Vist 109 gange

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 28. mar 2020, 21:08

så det auto install..
format.png
format.png (36.38 KiB) Vist 109 gange

lader ubuntu klare det med partition.
vælge.png
vælge.png (53.99 KiB) Vist 109 gange

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 28. mar 2020, 21:11

efter lidt tid ca 15-20 min.
grub.png
grub.png (180.48 KiB) Vist 109 gange

og andet tekst efter fejl.
tekst.png
tekst.png (26.43 KiB) Vist 109 gange

og så problem report.
problem-raport.png
problem-raport.png (95.35 KiB) Vist 109 gange

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 28. mar 2020, 21:12

men sådan ser den ud efter install. auto install
ubuntu-setup.png
ubuntu-setup.png (52.5 KiB) Vist 109 gange

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 28. mar 2020, 21:19

jeg har i bios Disabled fast Boot. Disabled Secure Boot!
og fik lavet SATA Mode om..
EMMC MODEL NAME: Hynix HCG4a2
SATA MODE: AHCI
jeg har også prøvet system boot mode med select an UEFI file as trusted for executing, og addet de som er i efi mappen på Ubuntu live Cdén... logger bare ind i grub 2, noget med sort skærm har prøvet, med de som var der, grubex64.efi og mmxx64.efi... uden held..

men som sagt så ved jeg at jeg kan bruge shimx64.efi og sæt den til først at boot i bios.. så kommer jeg direkte på den usb Kingston SDD HD... som jeg også have fejl med at installere på pga det med grub fejl.. men fik den op og køre aligevel ved at smide den i boot/efi mappen den shimx64.efi. men den kan boot op i fast boot osv
men det kan jeg ikke med den ubuntu install jeg har lavet på C drevet? for så opstår der en masse fejl og programmet lukker ned eller går ud?

AJenbo
Admin
Indlæg: 20519
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf AJenbo » 28. mar 2020, 22:19

Ok det ser rigtig ud. problemet kan måske løses ved at manuelt installere GRUB. Det vil jeg prøve at beskrive lidt i morgen, nu hvor vi ved hvad dvs paritioner heder efter installationen.

nemes543 skrev:GPT.. men om jeg formater den eller ej er den GPT i windows 10 også?

Er ikke sikker på hvad du spørg om her, men Windows understøtter GPT hvis det er det du spørg om.

nemes543 skrev:jeg har i bios Disabled fast Boot. Disabled Secure Boot!

Har du prøvet at sætte den til Legacy on installere når den er i den tilstand? Så er der nemmelig ikke brug for ESP eller grub-efi.
(kan se Aser også nogle gange kalder det for CSM boot mode)

nemes543 skrev:men det kan jeg ikke med den ubuntu install jeg har lavet på C drevet?

c-drevet er den primæer partition i en Windows installation, jeg er ikke hel sikker på hvad det er du refere til her. Mener du den interne disk (mmvblk0), (c-drevet var mmcblk0p4).

nemes543 skrev:for så opstår der en masse fejl og programmet lukker ned eller går ud?

Kan du eventuelt vise nogle af disse?

Fik du prøvet med MBR frem for GPT?

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 30. mar 2020, 11:51

fik gparted til at funger.. samt andre programmer ;)

Kode: Vælg alt

sudo apt-get install --reinstall libgtkmm-2.4-1v5 libatkmm-1.6-1v5 libpangomm-1.4-1v5 libglibmm-2.4-1v5 libsigc++-2.0-0v5 libcairomm-1.0-1v5

AJenbo
Admin
Indlæg: 20519
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf AJenbo » 30. mar 2020, 12:07

Det er måske en god ide at køre følgende på den:*

Kode: Vælg alt

sudo apt install -f

AJenbo
Admin
Indlæg: 20519
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf AJenbo » 30. mar 2020, 12:17

AJenbo skrev:Ok det ser rigtig ud. problemet kan måske løses ved at manuelt installere GRUB. Det vil jeg prøve at beskrive lidt i morgen, nu hvor vi ved hvad dvs paritioner heder efter installationen.

Prøv at køre følgende efter installationen fejler:

Kode: Vælg alt

sudo grub-install --root-partition=/target /dev/mmcblk0p2


Hvis ikke det virker så mount ESP som /target/boot/efi og kør følgende:

Kode: Vælg alt

sudo grub-install --root-partition=/target /dev/mmcblk0p2 --efi-directory=/target/boot/efi

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 30. mar 2020, 17:00

okay det forsøger jeg lige sener :)
for lige nu har jeg fået ubuntu 18 op og køre på usb kingston SDD. selv om jeg får følgende fejl under install.
grub-efi-amd64-signed’ package failed to install into /target/

også selv om jeg har brugt boot repair fra live cd, og den lokale disk ikke har partition fik jeg stadig den besked.
Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].

så prøvet at følge forslaget med at lave en ny opsætning af efi med Gparted og køre boot repair igen. og fik fejlen igen med Locked-ESP, med den opsætning gav flere fail report, efter jeg var logget ind.
    /dev/sda1 "efi"
    /dev/sda2 "swap"
    /dev/sda3 "ext4"
så lavet jeg en ny opsætning. men fik også samme besked med Locked-ESP.
men den her opsætning ser sådan ud.
    /dev/sda1 "efi" flag boot,esp
    /dev/sda2 "1MiB ukendt" flag bios_grub
    /dev/sda3 "swap" linux-swap
    /dev/sda4 "ext4" /
men i grub.cfg viste den at der er en menuentry: windows boot manager på /dev/mmcblk0, selv om den ingen styrsystem har på sig, så fjernet jeg windows boot manager med grub customizer samt unøvendige entry. så nu fungere ubuntu når jeg booter den op fra usb skal bare trykker F12 og vælge disken... og vil jeg boote direkte ind på ubuntu fra den externe harddisk, skal jeg sætte shimx64.efi først i bios så logger den ind, og lige meget om jeg har aktiveret eller deaktiveres fast Boot. kommer jeg ind... og opdatering virker og alt andet, efter jeg fik opdateret det med:

Kode: Vælg alt

sudo apt-get install --reinstall libgtkmm-2.4-1v5 libatkmm-1.6-1v5 libpangomm-1.4-1v5 libglibmm-2.4-1v5 libsigc++-2.0-0v5 libcairomm-1.0-1v5

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 30. mar 2020, 21:41

det er fra live cd for kan ikke boote, jeg har provet dit forslag.
efter.png
efter.png (79.47 KiB) Vist 76 gange
efter2.png
efter2.png (52 KiB) Vist 76 gange

nemes543
Indlæg: 90
Tilmeldt: 16. mar 2020, 15:37

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf nemes543 » 30. mar 2020, 21:45

brugte boot repair bagefter dit forslag, og saa provet jeg dit forslag igen saa kom den her besked... nu maa vi se.
ny.png
ny.png (22.43 KiB) Vist 76 gange

AJenbo
Admin
Indlæg: 20519
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Ubuntu 18.04.4 LTS hjælp

Indlægaf AJenbo » 31. mar 2020, 13:59

Hvis du kigger på fejlbeskeden kan du se at kommandoen ikke gjorde noget, selv om du forsøg 6 gange, da den ikke kender " --root-partition" delen. Jeg har vist også fået overset at du først skal montere /dev/mmcblk0p1 (din ESP). Så prøv følgende i stedet. (men jo boot repair ser ud til at have fundet den rigtige ESP for en gangs skyld)

Kode: Vælg alt

sudo mount /dev/nvme0n1p1 /mnt
sudo grub-install --efi-directory=/mnt /dev/mmcblk0p2


Her er også et par alternative du kan prøve hvis du bliver desperat:

Kode: Vælg alt

sudo grub-install /dev/mmcblk0p2
sudo grub-install --target=x86_64-efi --efi-directory=/mnt --bootloader-id=GRUB

Tilbage til "Installation"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster