Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520 Emnet er løst

Her kan du få hjælp til installationen af Ubuntu.
Klaus Rasmussen
Admin
Indlæg: 5262
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf Klaus Rasmussen » 23. apr 2017, 13:29

Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 21.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 13:50

Tak, Klaus. Men den user guide du linker til, er vist den samme som jeg selv fandt, og hvor jeg ikke kan finde noget videre om BIOS/UEFI, som jeg lige skrev. Og exe-filen du nævner, ved jeg ikke hvad jeg skal gøre med/bruge til. Skal jeg gøre noget inde fra Windows?

Men som sagt tror jeg hellere jeg bare må prøve at gå ind i BIOS'en og se hvordan det ser ud. Jeg har bare ikke haft tid endnu. (Er mor til en 4-årig, så jeg kan ikke sidde her hele dagen, men må gå en del til og fra).

Jeg vender tilbage når jeg er derinde, hvis jeg bliver i tvivl om hvad jeg skal gøre.

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 14:41

Nå, jeg ville lige prøve én gang til om jeg kunne starte live-systemet fra 17.04-dvd'en, men det gik præcis som før (med "low graphics mode"-problemet). Mærkeligt, eftersom det jo lykkedes allerførste gang jeg prøvede.

Men det betyder så også at jeg ikke umiddelbart kan komme ind og teste netkortet i 17.04.

Så er det vel bare at kaste mig ud i dét med BIOS'en og håbe det bedste.

Hvis det nu går fint med at deaktivere RAID, og jeg så vil forsøge at installere (eller i hvert fald prøvekøre) Ubuntu derefter, bør jeg mon så prøve med 16.04.2 LTS eller med 17.04? Nu fandt vi jo ikke ud af dét med om netkortet virker bedre i 17.04.

Klaus Rasmussen
Admin
Indlæg: 5262
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf Klaus Rasmussen » 23. apr 2017, 15:11

marie@idiomatic skrev:Hvis det nu går fint med at deaktivere RAID, og jeg så vil forsøge at installere (eller i hvert fald prøvekøre) Ubuntu derefter, bør jeg mon så prøve med 16.04.2 LTS eller med 17.04? Nu fandt vi jo ikke ud af dét med om netkortet virker bedre i 17.04.

Det kan jeg sige noget mere præcist om når du viser resultatet af kommandoen med Network.
Med Venlig Hilsen
Klaus

Kører Ubuntu 20.04 på Lenovo-H515s, 64bit og 21.10 på HP Probook 4520s, 64 bit.
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 16:19

Nu er jeg endelig kommet lidt videre:

Jeg ændrede til AHCI og havde derefter held til at starte 16.04.12 LTS-live-systemet fra dvd'en.

Men: Jeg fik stadig den samme fejlmeddelelse under opstarten som før! Altså den med "unknown controller" og "unknown chipset" osv. Og Ubuntu var lige så lang tid om at starte op som før (ved ikke om dét har noget med sagen at gøre).

Ikke desto mindre vises diskene nu ude til venstre:
entire.workspace.png
entire.workspace.png (477.87 KiB) Vist 433 gange


og jeg har fået følgende output:
sudo-gdisk-l-dev-sdb.png
sudo-gdisk-l-dev-sdb.png (90.04 KiB) Vist 433 gange

sudo-gdisk-l-dev-sda.png
sudo-gdisk-l-dev-sda.png (77.49 KiB) Vist 433 gange


Sender mere om lidt, for jeg kan tilsyneladende ikke uploade flere filer ad gangen end disse.

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 16:23

Manglede lige den her:
sudo-parted-l.png
sudo-parted-l.png (123.84 KiB) Vist 433 gange


Og så har jeg fået følgende resultater ift. netkort:

Anders' metode:
lspci -nn | grep -i net
03:00.0 Network controller [0280]: Intel Corporation Device [8086:24fd] (rev 78)
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)

Klaus' metode:
lspci | grep Network
03:00.0 Network controller: Intel Corporation Device 24fd (rev 78)

Og det er altså 16.04.2 LTS lige nu, for jeg ved ikke om jeg kan starte 17.04 - har mine tvivl. Skal jeg prøve, eller hvad er næste trin? Det ser jo ikke ud til at alt er helt som det skal være endnu, så vidt jeg kan se.

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 16:30

Og undskyld jeg ikke copy-pastede det hele - tænkte at det ville være svært at læse ved så lange output, men jeg skal nok prøve næste gang. Skal lige lære formaterne herinde at kende.

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 16:38

Har fået et nyt svar herinde:
https://ubuntuforums.org/showthread.php?t=2359208
Kan I hjælpe mig med at forstå det? Det er mest dét her:
"Be sure to use Windows tools to shrink the Windows NTFS partition and reboot immediately so it can run chkdsk.
Make sure Windows fast start up is off and in UEFI its fast boot is off."

Og så selvfølgelig alt dét han skriver her:
https://ubuntuforums.org/showthread.php?t=2147295
Det er mig komplet uoverskueligt.

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 16:41

Jeg er nødt til at holde en længere pause nu (af familiemæssige årsager). Kommer tilbage til det i aften, medmindre jeg beslutter at opgive indtil videre, for nu er RAM'en i mit hoved ved at løbe fuld igen, og jeg synes atter at jeg intet fatter. Men måske hjælper det med en pause.

AJenbo
Admin
Indlæg: 20677
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520  Emnet er løst

Indlægaf AJenbo » 23. apr 2017, 19:49

Du burde nu kunne installere ubuntu. Dog vil det måske ikke spille optimalt med Windows som det er sat op pt. Og wifi er jo også stadig et uløst problem.

De råd du får i den anden tråd er lidt de teknisk optimale, men nok ikke de nemmeste at følge.

Hvis blot du deaktivere fast startup i Windows behøves du ikke at bruge Windows værktøjer til at skrumpe Windows disken (vælger du allerede nu at installere ubuntu som eneste system vil det ikke være nødvendigt og du kan stadig installere Windows fra din usb hvis du vil gå tilbage). Du kan se hvordan her:
https://www.google.com/amp/www.pcadviso ... 021/%3Famp
Resten kan ubuntu selv håndtere.

Som jeg forstår det tilgår du uefi indstillingerne ved at trykke på en særlig knap under opstarten (og ikke ved at vælge den fra Windows), i så fald behøves du ikke deaktivere fast boot.

Exe filen Klaus linkede til sørge for at din UEFI er opdateret, det ville være godt at køre den i Windows inden du fortsætter da det kan afhjælpe eventuelt problemer med maskinen. Bemærk at du muligvis skal deaktivere raid igen bagefter.

AJenbo
Admin
Indlæg: 20677
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf AJenbo » 23. apr 2017, 19:58

Den langsomme opstart kan skyldes at du starter systemet fra en dvd hvilket er et noget sløv, det ville være hurtigere med en USB, dog køre live systemer altid lidt langsommere end Når du har installeret det på computeren.

Hvis du på et andet tidspunkt hænger fast som med 17.04 kan du blot holde tænd knappen nede i 10 sekunder for at slukke maskinen, når du køre et system live fra en dvd vil der ikke være nogen risiko for at der sker en fejl (så længe du ikke er gået igang med at installere eller på anden måde rode med filerne på computerens harddisk).

Jeg mistænker lidt at din maskine har mere end et grafikkort, selvom det tidligere så ud som om der kun var 1 Intel kort. Det kan være grunden til at du får low graphics. Måske kan det hjælpe at starte med nomodeset :
https://ubuntudanmark.dk/blog/artikler/ ... nomodeset/

Du tager bare alle de pauser du har brug for, det er jo ikke os der mangler en computer :-)

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 20:13

Pyh - tak, Anders, fordi du utrætteligt forklarer mig tingene og går ind i detaljerne. Det kunne da lige passe at jeg skulle give op så kort før målet, når du siger at jeg burde kunne installere nu.

Jeg må lige prøve at læse på de links du giver, og så vender jeg tilbage, for der er helt sikkert noget af dét du skriver, jeg lige har brug for at få forklaret endnu mere - men jeg må hellere lige læse det hele før jeg spørger igen.

Dog et enkelt spørgsmål: Var det mon tilfældigt at jeg løb ind i low graphics-problematikken to gange med 17.04, men ikke med 16.04.2 LTS? Jeg er nemlig stadig i tvivl om om jeg skal prøve at installere den ene eller den anden version.

Mens du/I tænker over dét, vil jeg lige nærlæse dine svar og de sider du linker til.

AJenbo
Admin
Indlæg: 20677
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf AJenbo » 23. apr 2017, 20:15

Jeg har lige undersøgt sagen med wifi, den kræver blot at man køre Linux 4.8, så det burde virke efter installationen af 16.04.2, men kræver muligvis at den henter nogle opdateringer fra nettet. Har du mulighed for at få maskinen på nettet via et kabel eller en usb-wifi-chip?

AJenbo
Admin
Indlæg: 20677
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf AJenbo » 23. apr 2017, 20:19

Problemet med low mode er nok at 17.04 næsten under støtter det ekstra grafikkort, men 16.04 slet ikke gør. Jeg vil foreslå du prøver 16.04 og så ser vi om ikke vi kan få wifi til at spille der (det burde virke i 17.04). Jeg går ikke ud fra du skal bruge det ekstra grafikkort til noget (generelt er det frarådet at købe maskiner med flere grafikkort hvis man vil køre Linux)

marie@idiomatic
Indlæg: 334
Tilmeldt: 13. nov 2008, 22:11
IRC nickname: marie

Re: Installer finder ikke SSD og HDD: Ubuntu 16.04 LTS på Lenovo Y520

Indlægaf marie@idiomatic » 23. apr 2017, 20:42

Jeg er ikke bekendt med at der skulle være to grafikkort - sælgeren sagde i hvert fald ikke noget om det, og jeg kan heller ikke se at der står noget om det på produktsiden. Men hvad ved jeg :-/

Men godt, vi prøver 16.04 som først planlagt. Den giver jo også længere support.

Tak for at du har undersøgt dét med wifi. Sælgeren sagde at man godt kunne tilslutte den netværk med kabel, ja, og jeg kan se i manualen at der er en "RJ-45 port" hvorom der står: "Connects the computer to an Ethernet network." Det må vel være den jeg skal bruge. Men hvad søren er det for et stik jeg skal bruge dér? Porten ser mindre ud end jeg er vant til fra gamle dage ... Skal jeg mon ud at købe et nyt netkabel i morgen (eller en adapter af en slags)?

Jeg er ikke færdig med at læse, men det lyder som om det næste jeg skal, er at starte Windows for at opdatere UEFI og deaktivere fast startup. Skal jeg så ændre AHCI tilbage igen før jeg booter Windows?

Tilbage til "Installation"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster