Failed to start the X server efter updates.

Her kan du få hjælp til installationen af Ubuntu.
deepcore
Indlæg: 23
Tilmeldt: 6. sep 2007, 18:40

Failed to start the X server efter updates.

Indlægaf deepcore » 7. nov 2007, 21:16

Jeg downloadede nye opdateringer til ubuntu 7.4
Derefter bad den mig genstarte.

Herefter får jeg beskeden efter opstart:

Failed to start the X server (your graphical interface).
It is likely that it is not set up correctly.
Would you like to view the server output to diagnose the problem?

Jeg kan så vælge Yes eller No.

Hvis jeg vælger Yes får jeg en længere smørre, men dette ser ud til at være humlen:

Error: API mismatch: this NVIDIA driver has version 100.14.09, but the NVIDIA kernel modules's version does not match.
Please make sure that the kernel module and all NVIDIA driver components have the same version.

(EE)NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE)NVIDIA(0): that the NVIDIA device files has been created properly
(EE)NVIDIA(0): Please consult the NVIDIA README for details.
(EE)NVIDIA(0): ***Aborting***
(EE)NVIDIA(0): Screen(s) found, but none have a usable configuration.

Fatal server errror: No screens found.
--------

Hvis jeg vælger "NO" får jeg beskeden:
The X server is now disabled. Restart GDM when it is configured correctly


Jeg kan godt regne ud at de der updates har blastet mit grafikkort. Det virkede ellers så fint inden, hardwareacceleration og alting.

Hvad gør jeg, hvordan retter jeg fejlen? ... Jeg kan ikke komme ud i en prompt når jeg exiter fejlskærmen. (ok, man kan sikkert få den frem, jeg ved bare ikke hvordan)

På forhånd tak for hjælpen :)

deepcore
Indlæg: 23
Tilmeldt: 6. sep 2007, 18:40

Failed to start the X server efter updates.

Indlægaf deepcore » 7. nov 2007, 21:36

Ok, det lykkedes at skifte til en virtuel konsol.
Der lå heldigvis en backup a xorg.conf som jeg kunne overskrive den nye med.
- og voila, så virkede alt igen.

Jeg ville dog gerne alligevel vide hvad der monstro gik galt, og gerne en kort beskrivelse af hvad man kunne gøre for at rette problemet, hvis man ikke lige havde en backup til rådighed.

(jaja, jeg ved godt det ikke er et kristisk problem mere - men jeg prøver desperat at finde ud af hvordan alt det her virker)

eitreach
Indlæg: 2478
Tilmeldt: 24. jul 2007, 19:32
IRC nickname: eitreach
Geografisk sted: København

Failed to start the X server efter updates.

Indlægaf eitreach » 7. nov 2007, 21:59

Jeg ved ikke hvor meget der kan gøres nu, men hvis det sker igen, så prøv at tage en kopi af den xorg du står med, som ikke virker, og sammenlign den med en backup - det er den nemmeste måde at lære hvordan de forskellige indstillinger virker, synes jeg. :)

red: Det du kunne gøre nu, er også at begynde at kigge lidt i den, fra tid til anden - specielt det der drejer sig om dit grafikkort, da det som regel er der det går galt - men når man først lige får styr på den del, så begynder de andre dele også langsomt at give mere mening.
"A Narn heavy cruiser?!"

Fornuftig opførsel: faq.php#f00
Guide til ooh shiny: viewtopic.php?f=11&t=2189
Guide til 3d-effekter: viewtopic.php?f=11&t=4393

Tilbage til "Installation"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster